"Screen locker is broken" on plasma X11 with nvidia hybrid set

The screen is locking with a black-white message “The screen locker is broken and unlocking is not possible anymore …” and approach from related topic Kscreenlocker broken after yay -Syu does not help.
Running lookandfeeltool -a org.kde.breeze.desktop gives:

qt.qpa.xcb: could not connect to display  
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may
fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xco
mposite-egl, wayland-xcomposite-glx, webgl, xcb.

Reinstalling libxcb and xcb-util did not help also.

Details:

$ inxi -G
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia
    v: 510.73.05
  Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1 driver: X:
    loaded: nvidia gpu: i915,nvidia,nvidia-nvswitch resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 1060 with Max-Q Design/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.73.05
$ inxi -b
System:
  Host: roman-pc Kernel: 5.17.1-3-rt17-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.24.5 Distro: Manjaro Linux
...
$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI


Warning: No installed USB configs!
$ cat  /usr/share/sddm/scripts/Xsetup
#!/bin/sh
# Xsetup - run as root before the login dialog appears

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

If this happens while doing the update, or right after the update was finished, you have to reboot the system.

You do not need all the drivers installed. video-linux has no use for your hybrid graphics laptop …

not quite, not really (I would say the nvidia problems started right after update)

did reboot many, many times. Prehistory is Screen image distortion on resume - #67 by RomanPerekhrest

When running /usr/lib/kscreenlocker_greet --testing I get:

$ /usr/lib/kscreenlocker_greet --testing
Locked at 1656336119
Cannot mix incompatible Qt library (5.15.3) with this library (5.15.5)
Aborted (core dumped)

But reinstalling qt (entire package with subsequent/dependent ones) and kscreenlocker, along with rebuilding qt5-styleplugins (as shown in Screen locker is broken) did not help.


$ lookandfeeltool -a org.manjaro.breath-light.desktop                                            
QDBusConnection: error: could not send signal to service "" path "//home/roman/.kde4/share/config/kdeglobals" interfac
e "org.kde.kconfig.notify" member "ConfigChanged": Invalid object path: //home/roman/.kde4/share/config/kdeglobals
QDBusConnection: error: could not send signal to service "" path "//home/roman/.kde4/share/config/kdeglobals" interfac
e "org.kde.kconfig.notify" member "ConfigChanged": Invalid object path: //home/roman/.kde4/share/config/kdeglobals
QDBusConnection: error: could not send signal to service "" path "//home/roman/.kde4/share/config/kdeglobals" interfac
e "org.kde.kconfig.notify" member "ConfigChanged": Invalid object path: //home/roman/.kde4/share/config/kdeglobals