Screen Lock/Password Issue

Expected Behavior: Hit the “suspend” button. Require a password upon waking.

Actual Behavior: No password required.

I figured out that if I turn “Automatic Screen Lock” off, then I never get prompted for a password after suspending. If I turn the automatic screen lock on, I get the password screen.

The issue is, I don’t want the Automatic Screen Lock. I would like my screen to go blank after a period of time, but I never want it to lock on its own. I always (when not suspended) want to be able to move the mouse and have immediate access to the screen. If I activate the automatic screen lock, even at the longest delay, it’s just an hour.

Is there not a way to leave the “Automatic Screen Lock” set to “off” while also having to enter my password when waking from suspend?

I assume there’s a way and I’m just derping hard. I’m a newly returned Manjaro user and I’ve not been on Gnome in years.

Thanks in advance (about to sleep, so it will be a long time before I reply).

I didn’t want to bump this, but if there’s no legit answer for it, maybe it’s something the Manjaro team needs to be aware of?

It’s been 5/6 days since posting this and with no activity. I’m going to assume that it’s simply impossible to do in the current state.

May I request an admin to suggest it as a feature for a future update? I’m not sure how that works or if I’m allowed to personally make such request. You have my permission to link, move, quote, etc my post in whatever relevant place if it helps get the issue resolved.

Thanks. <3

I’m almost positive that this is a configuration issue - some lock screen setting that you set to disable or some power management option in the Gnome preferences somewhere.

other people want the opposite - they are annoyed that they land at a lock screen after suspending and waking up …

I assumed it was just some way I had my settings laid out, but for the life of me, I spent an hour trying to fumble around with it to no avail. But I was able to isolate the issue down to that automatic screen lock setting. I tested it a couple times.

And yeah, no, I totally get what you’re saying. I don’t personally want to have to put in my password when I simply walk away from the computer for an hour and leave it running. Sometimes I’m just waiting on a download or something and don’t want to be fussed with the password.

However, I often hit suspend when I’m away for hours at a time and I don’t want people to be able to boot my computer and snoop. I have roommates. Not that I don’t trust them, but there’s clearly people around.

Point being, there should be a way that I can password protect suspend without having the automatic screen locking feature when I walk away for a bit too long. I should be able to allow my screen to go black without it locking some period of time afterwards, and as it sits right now, I believe 1 hour was the maximum amount of time I could set the screen lock for after screen blanking.

But yeah. I totally “get it.” But that’s exactly why I feel the optionality needs to be there, and it currently seems not to be.

If you turn off automatic screen locking for gnome’s gdm completely, you can still lock it manually before suspend or whenever you want.
If you want to deviate even more from the defaults and want to automate locking on suspend while keeping the other automatism off, you need to turn to customize systemd, which is responsible for the suspend. In this case, the wiki has you covered, but expect troubleshooting.

1 Like

Usually, for all suspend operations, you need to enter the password to unlock your session.
It is either a configuration setting, maybe auto-login or some plugin like caffeine which interferes with lock/suspend/screen events, or did you check that your system actually does suspend correctly?

Maybe there is something in the journal that might tell what’s going on; or rather doesn’t.

He turned it off:

That’s why I wrote about changing systemd default units.