Screen keeps turning off despite power settings

My screens keep turning off (not locking) after probably ten minutes or so, I haven’t had the time to sit down and time my monitors. Every setting in kde has lock screen or power management set to off, I can ensure. I installed xfce a while back alongside kde (i know) and ended up removing it and have no issues with kde besides this. I’m not sure that the xfce install is the reason or not. Right now I’m using caffeine in autostart as a workaround. I don’t want my displays to turn off, thanks.

edit: Failed to mention they don’t turn off unless I’m inactive

1 Like

if it’s on the login screen,then it’s normal.

It’s not I’m not even sure if it happens on the log in screen. It’s happening when I’m logged in.

I had this issue in my first Manjaro installation many years ago (screen was going black when I was watching a Youtube video, and KDE settings weren’t doing anything to help even if I had 20 minutes before screen saver, it was going black after 10 minutes / 600 seconds). It was an X setting about DPMS. Not exactly sure what I did back then, I think I disabled blanking.

check your values with xset q

My current settings:

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Disabled

//EDIT: what I probably did was xset s off -dpms

I still have in KDE System Settings → Power Management the Screen Energy Saving enabled and set to 10 minutes, but it will not trigger unless there is no video playing or other significant activity.

I have done this and have identical values to your xset q. I remember doing

xset s off -dpms

myself now that you mention it. Screens still turn off unfortunately. Thanks for your help with both of my topics by the way

And you checked the KDE settings I mentioned?

Yeah, in my first post I verified every KDE setting is disabled. I’ve even tried enabling screensaver with values of 0 in every KDE screensaver/screenlock/powersave option. I’ll try it again for the hell of it.
have this set as well.
Could this be causing issues?

Then I’m out of idea. Try to set very high value then to see if it helps to try to locate the culprit.

Not sure how that would help (in testing) but it seems as though both of my issues have no solution other than autostart workarounds. To anyone in the future, install caffeine, have it enable on boot with

/usr/bin/caffeine -a

in autostart

You could uninstall PowerDevil maybe, I think it is the KDE package that manages power settings. No guarantee it will not mess things up, just a suggestion.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.