Screen gamma adjust. A How To (of sorts)

I trust this feature will eventually arrive in KDE but until then I think I have a work around for adjusting individual gamma settings on my dual monitor set up.

The first monitor is the laptop screen of my Dell M1330, the second monitor is a Dell 24" external monitor.

Right now the ability to set gamma of individual displays is greyed out. Grrr.

The gamma of the laptop screen is deficient, imho compared to the external Dell monitor.

What I did so far, was bump up the gamma 30% in settings. Then, using the hardware controls on the side of the external monitor I dropped the brightness from 80 to 65%. The laptop monitor is still lagging, but it is WAY better. Will continue to tweak.

There is a simple small monitor calibration programm called monica in the AUR.
If you don’t have a calibration tool this will help a little bit.

2 Likes

Thanks! I did not know about this.

I just now tried to install it from AUR but it failed because of “treating warnings as errors”. Oookaayy.

Maybe I can find a compiled package. :slight_smile:

I see others are getting the exact same errors that I got:

https://aur.archlinux.org/packages/monica

Hmm.

Oh, this was not successful. Looks like it is unmaintained. But now, you should have xorg-xgamma already installed, as a dependency for monica.
Now you are able to correct gamma settings, by just typing a oneliner to your ~/home/yourusername/.profile

example:

export xgamma -quiet rgamma 0.98 ggamma 1.02 bgamma 1.01

…is adjustable (1.00 is deault), you get the idea.
…try and error…
:hammer_and_wrench:

1 Like

Ah ha! thanks.

Working on another front the fun continues. LOL!

I downloaded and ran the install script for

GAMMApage

written in python. It seemed to install ok as per:

sudo python setup.py install

But when I run it, I get this error:

TabError: inconsistent use of tabs and spaces in indentation

Scratch that. xrandr has gamma abilities. I can adjust the monitors separately which is what I want to do.

~

xrandr
Screen 0: minimum 320 x 200, current 3200 x 1080, maximum 8192 x 8192
LVDS-1 connected primary 1280x800+0+0 (normal left inverted right x axis y axis) 290mm x 180mm
1280x800 60.04*+
1024x768 59.95
800x600 59.96
640x480 59.94
720x400 59.97
640x400 59.96
640x350 59.84
VGA-1 connected 1920x1080+1280+0 (normal left inverted right x axis y axis) 477mm x 268mm
1920x1080 60.00*+
1280x1024 75.02 60.02
1152x864 75.00
1024x768 75.03 60.00
800x600 75.00 60.32
640x480 75.00 59.94
720x400 70.08
HDMI-1 disconnected (normal left inverted right x axis y axis)

I want to adjust VGA-1

The values in order are red, green, blue.

I discovered using whole numbers is NOT what I want.

But you can use decimal places. For example:

xrandr --output VGA-1 --gamma 1.08:1:1

adds just a bit more red to the screen.

The tweaking continues. :smiley:

1 Like

I may have to go back to using my monitor’s screen adjusters. Xrandr is easy and precise and I have it set to my liking but I have not found a way to keep the screen settings persistent from boot to boot.

Woo hoo I did it.

The secret is that the xrander script I created needs to run after the desktop loads and is fully on screen. Would the sleep command work?

Using a sleep 32 command seemed extreme, but right after the desktop loads, the screen changes to the xrandr settings. !!!

So, I consider this problem SOLVED baby!