Screen flickering with Intel on-board graphics, Lenovo 11e laptop

Hello everyone,

I’m running a fresh install of Manjaro on my Lenovo 11e (3rd generation) laptop, and am experiencing the common screen flicker problem. With this and one or two other exceptions (intermittent freezing and tearing, the latter I think due to a compositor issue), this is so far the best OS I’ve ever used. I’m hoping I can resolve these problems - the screen flicker being the worst because it’s constant - and enjoy many years of Manjaro computing. :slight_smile:

I have already tried one suggested solution, being creating a .conf file in /etc/X11/xorg-conf-d and enabling the TearFree option for the GPU driver, but this seems to have done nothing.

Thank you for any help you might be able to provide!

inxi -Fxza --no-host reads:

Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64
root=UUID=d6ea7aff-f2bc-4e36-9da8-3a232a139d00 rw quiet apparmor=1
security=apparmor resume=UUID=2ea055a9-3add-4c5b-8d8b-1034d83446cc
Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Type: Laptop System: LENOVO product: 20G9S0A108 v: ThinkPad 11e 3rd Gen
serial: Chassis: type: 10 serial:
Mobo: LENOVO model: Intel powered classmate PC v: SDK0J40697 WIN
serial: UEFI [Legacy]: LENOVO v: R0AET28W (1.11) date: 06/13/2016
ID-1: BAT1 charge: 42.3 Wh condition: 42.1/42.0 Wh (100%) volts: 12.8/11.2
model: SMP LNV-00HW44 type: Li-poly serial: status: Discharging
Topology: Quad Core model: Intel Celeron N3150 bits: 64 type: MCP
arch: Airmont family: 6 model-id: 4C (76) stepping: 3 microcode: 368
L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 12805
Speed: 480 MHz min/max: 480/2080 MHz Core speeds (MHz): 1: 521 2: 499
3: 480 4: 480
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass status: Not affected
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx
Integrated Graphics
vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b1
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
bus ID: 1-3:2 chip ID: 04f2:b55d serial:
Display: x11 server: X Org 1.20.8 driver: intel display ID: :0.0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 133 size: 260x150mm (10.2x5.9")
diag: 300mm (11.8")
OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (BSW) v: 4.6 Mesa 20.1.7
compat-v: 3.0 direct render: Yes
Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series
High Definition Audio
vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1b.0
chip ID: 8086:2284
Sound Server: ALSA v: k5.7.19-2-MANJARO
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 1000 bus ID: 02:00.0
chip ID: 10ec:8168
IF: enp2s0 state: down mac:
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 1000
bus ID: 03:00.0 chip ID: 8086:095b
IF: wlp3s0 state: up mac:
Local Storage: total: 356.23 GiB used: 34.38 GiB (9.7%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda vendor: Samsung model: MZNTY256HDHP-000L7 size: 238.47 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
serial: rev: 3L6Q scheme: MBR
ID-2: /dev/sdb type: USB vendor: Generic model: SD MMC MS PRO
size: 117.75 GiB block size: physical: 512 B logical: 512 B
serial: rev: 1.00 scheme: MBR
ID-1: / raw size: 229.67 GiB size: 225.06 GiB (97.99%)
used: 34.38 GiB (15.3%) fs: ext4 dev: /dev/sda1
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda2
System Temperatures: cpu: 47.0 C mobo: 0.0 C
Fan Speeds (RPM): cpu: 0
Processes: 185 Uptime: 17m Memory: 7.60 GiB used: 901.8 MiB (11.6%)
Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1126
lib: 342 flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal
inxi: 3.1.05

mhwd -li reads:

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs

Hello marianas,
If you haven’t done it yet, I would suggest running pamac update, I am not sure about the where the mainline kernel is, but 5.7. may not be the newest one (forgive me if i’m wrong).

Online, the solution seems to have been to reinstall the diver like shown here.

Unfortunately, this would require a windows 10 install, so the only solution that I can think of is to install windows 10, follow the tutorial if necessary and reinstall manjaro.
You probably wont have to activate windows for this.

I’m not really satisfied with that suggestion myself tbh.
Best Regards, Julius

But after you have reinstalled Manjaro the driver would be gone again, I think?

depends. I don’t know how they did it in the laptop.
It is certainly possible that it will just be gone. Some store drivers independent of the os on the motherboard.
Quite frankly, I don’t know.

Thank you julius-gu, that is good to know although not very satisfying to myself either. But I appreciate the help. :slight_smile:

I ran pamac update to no avail. I also attempted to solve the problem by disabling Panel Self Refresh, first by disabling the kernel parameter and then by installing an old kernel that does not support the parameter. Neither worked, so I can rule that out at least. If I have to install windows to fix it I will likely just deal with it, but we’ll see - I hope I can find another solution.