Screen Flickering Nvidia Card Intel

Hello forum, I have installed manjaro, it is a clean installation, with proprietary Nvidia drivers, but I have random screen flickers, I tried changing the refresh rate like the wiki variable refresh rate , creating the /etc/X11/xorg.conf.d/20-intel.conf file and putting this:

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option "TearFree" "off"
        Option "EnablePageFlip"  "off"
        Option "VariableRefresh" "false"
        Option "AsyncFlipSecondaries" "false"
        #Option      "AccelMethod"  "sna" # default
        #Option      "AccelMethod"  "uxa" # fallback

But it doesn’t work, I’m using x11 and 144 fps

Some additional data:

CPU: quad core Intel Core i3-9100F (-MCP-) speed/min/max: 3897/800/4200 MHz
Kernel: 6.1.31-2-MANJARO x86_64 Up: 23m Mem: 5506.1/15933.7 MiB (34.6%)
Storage: 2.71 TiB (15.4% used) Procs: 261 Shell: Zsh inxi: 3.3.27

sudo mhwd -li

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI

Warning: No installed USB configs!


Screen 0: minimum 8 x 8, current 3440 x 1440, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 connected primary 3440x1440+0+0 (normal left inverted right x axis y axis) 800mm x 330mm
   3440x1440     60.00 + 144.00*  100.00    50.00  
   2560x1440    144.00   120.00    60.00  
   2560x1080    144.00   120.00  
   1920x1200     59.88  
   1920x1080    119.88    60.00    50.00  
   1680x1050     59.95  
   1600x1200     60.00  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720     119.88    60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.95    59.94    59.93  
DP-1 disconnected (normal left inverted right x axis y axis)

What exactly do you want to do?

Your title indicates the problem is “screen flickering” with Nvidia but you tried to fix it by setting screen tearing options for Intel GPU, but you actually want VRR?

So what is it?

I found a post here that disabling the VRR solved the problem of screen flickering, can you suggest another way to solve it?

You did not specify what version of the video driver you are using, but as far as I understand this is the problem.

Known ways to fix it are to use a video driver up to version 530 (525) or to set the maximum performance for the video card

after 470 does not show the driver version, also in the post is the output of sudo mhwd -li, and when trying to install with sudo mhwd -a pci nonfree 0300 i skip the installation because it is already installed (Skipping already installed config 'video-nvidia' for device: 0000:01:00.0 (0300:10de:2187) Display controller nVidia Corporation TU116 [GeForce GTX 1650 SUPER]

You could use the command inxi --display -x -G -S to get all the information you need. As I said in my previous post, so far there are only 2 ways to solve this problem, maybe one of them will work for you. You can follow the current status of the problem on the Nvidia forum, the link is in my previous post.

This is the output of inxi --display -x -G, as you can see, i have the version 530, i’ll try in the Nvidia forum, thanks for the information,

  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: Gigabyte
    driver: nvidia v: 530.41.03 arch: Turing bus-ID: 01:00.0
  Display: x11 server: v: with: Xwayland v: 23.1.1 driver: X:
    loaded: nvidia gpu: nvidia resolution: 3440x1440
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX 1650
    SUPER/PCIe/SSE2 direct-render: Yes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.