Screen Flashing on Manjaro Guest on Virtualbox on mac

I install current manjaro kde plasma iso to virtualbox running on new MacMini. I did all updates after install, and installed the Guest Editions from Virtualbox. Below are a animated gif of problem and pic of virtual box setup. I have tried several different video memory and video adapter choices in VirtualBox. Nothing seems to fix this. Any solution is welcome:
ManjaroFicker
Screen Shot 2020-08-19 at 1.34.10 PM

Hello and welcome,

Even tho this is not quite fitted for a help request regarding Manjaro, i think we can address it.
From the settings of the Virtual machine seems you have just 32 MB dedicated for the virtual GPU.

image

While in the past that sufficed, for some guest OS installs, now is not. Please change to at least 128 MB, and once you reboot, check in Plasma Setting of the guest to be set to OpenGL3.1
All should run more smoother after that.

1 Like

I have set the Video Memory to 128 MG and have the same result.
Can you suggest a forum to I place this request: Virtual Box, Arch, etc? Reddit, stack overflow, vendor specific?

Since you are using an Apple device with the MacOS (OSx) on it as host, you should start there. What GPU has that MacMini? What OS version? What version of VistualBox runs on it?
I run 2 or 3 instances of Virtual machines at once on Manjaro host, on a not very powerful machine, and quite old by some standards, and i have no issues with the guest. What other guest OS have you installed? Does the same thing? Is this Manjaro guest installation set as image or is something else in VM settings?

Please don’t do that. Your issue has nothing to do with Arch in the sense to ask assistance or help. You will be booted from there in a plank-time, and rightfully so. :slight_smile:

I had the same problem, and the update of Vbox to 6.1.14 fixed it, however recent updates to Manjaro Gnome have created an unusable system, so back up and proceed with caution.