Screen Capturing Issue

Hello, I’m trying to capture my screen but captured video is like two cached images in a loop. So it doesn’t capture what I’m doing.

However, if I try to capture a specific window, it can capture the window correctly. Also, if I change the rendering backend to another backend and switch to my default (OpenGL 3.1) again, Firefox can capture my screen but not the same for other applications.
This is not an OBS issue by the way. Same for every application.

Things I tried:

  • Changing compositor settings (including vsync settings). Only XRender works properly for screen capturing but it doesn’t even support desktop effects like blur.
  • Asking for help on Manjaro Matrix room.
  • Asking for help on OBS Forum, nobody wrote anything.

My system:

  • OS: Manjaro 21
  • Kernel: Linux 5.11.10-1
  • DE: KDE Plasma 5.21.3
  • CPU: Intel Celeron N3450
  • GPU: Integrated Mesa Intel HD Graphics 500
  • RAM: 4 GB
  • Video driver: video-linux and Mesa. I don’t know versions.

My compositor settings:

  • Enable compositor on startup: Enabled
  • Scale method: Accurate
  • Rendering backend: OpenGL 3.1 (I tried OpenGL 2.0 too but it didn’t solve)
  • Latency: Balance of latency and smoothness
  • Tearing prevention (“vsync”): Automatic (I tried others too but it didn’t solve)
  • Keep window thumbnails: Only for Shown Windows
  • Allow applications to block compositing: Enabled

I have to share my screen tomorrow. Hope someone help because I couldn’t solve by myself. Thanks.

I noticed only Firefox is working properly for screen capturing and other applications (OBS, Zoom’s closed source desktop app, FFmpeg [to record screen using x11grab], SimpleScreenRecorder and Flameshot [screenshot tool]) are breaking screen capturing until I reboot my system. I also tried reinstalling the OS and issue is still occuring.

I have a similar problem when running Compiz, I can use screen capture again when temporarily switching to Xfwm (using Xfce on my machines). So, maybe try to deactivate compositing in your Plasma settings as a workaround?

Disabling compositing solves the screen capturing issue but it disables more effects than XRender. Do you have any idea for desktop effects?
Thank you for replying by the way.

Unfortunately not, I am also stuck with disabling the desktop effects whenever I need to record a screencast oder stream my screen.

Switched to Arch and the issue is solved for me now. If you are a Manjaro user experiencing this issue, I don’t know any other solution other than using XRender/disabling compositor. Have a nice day.

Oh my god, thanks a lot for asking this issue. I’ve had the same exact problem and I’ve been looking for what to do for WEEKS. Finally found a solution.