Screen Blank after Adjustment in Power Management Mode

I am wondering how I can via USB live mode to access Screen Brightness control under Power Management (Energy Saving page).

I was on Power Management page to make some changes. Then I saw an option for Screen Brightness adjustment, which was defaulted to 50%. I increase the brightness bar to the max 100%. There was no noticeable difference and then I clicked on “Apply”. My screen went blank as a result. Not sure if it is a bug with the Power Management.

Not able to view anything to reverse the action, I turned off my computer and restarted the system. The system booted up to the point of showing the moving three dots but the next screen expected to be the login screen was just blank.

I hope I can do something about changing it back via the USB live system. Does anybody know how? Thanks.

I think those settings are stored in ~/.config/powermanagementprofilesrc for KDE.

I have found the file. Changed the setting:
[AC][BrightnessControl] value back to ‘50’ from ‘100’ which seemed to be what I had done before the blank screen.

However, I still get the blank screen and not the login screen.

I attach the contents of this file as follows:



















Since I am currently using the system in live USB mode without any issues, it’s unlikely that the video drivers are the root cause of the problem. The fact that the issue only occurred after adjusting certain power management settings further supports this conclusion.

It’s more probable that the issue lies within the power management settings themselves or some other aspect of the system configuration.

Any suggestions where to find the fault or bug in this case?

Btw, I have also tried to login using “ctrl-alt-F1, F2, F3, etc” after the black screen but nothing happened. However, “ctrl-alt-del” did reboot the system.

I suggest moving that file to .bak and let KDE regenerate it with default values.

I don’t have the [AC][BrightnessControl] section at all.

I think the reason why you do not see the [AC][BrightnessControl] line at all is because there is a check box at the top of ‘Energy Saving’ section of the Power Management console that has to be ticked for the [AC][BrightnessControl] line to be shown on the ‘powermanagementprofilesrc’ file.

A developer friend of mine who does not use Linux and is not familiar with it suggested that my case sounded like the display driver and the KDE app might have been not quite “in sync” as the adjustment of brightness beyond a certain level had turned off the backlight altogether.

However, he also suggested to just try to enter my pw “in the dark” since I was supposedly already on the login page but just did not have graphics. It was something that I had suspected so but didn’t become obvious to me to act on.

Before doing as he suggested, whilst still in usb live mode, out of curiosity I simply tried adjusting desktop brightness levels with my pc’s ‘fn’ keys and my screen did go blank beyond 95% but readily responded otherwise.

So, I restarted my pc and upon the blank screen I entered my pw. Well, very glad that my system came on as if nothing had happened prior. Went in to change the brightness to 45% and then restarted with no issue there once again.

Checked the powermanagementprofilesrc file to confirm and yes, the [AC][BrightnessControl] line did show the value=45. I have since unticked that box and now the line is not there as per default setting.

Even though the issue is resolved but I would still like to understand where the ‘bug’ is for this to happen which might seem unusual as it seems like to have been hardware driver related.

Any idea on where to start the investigation?

Cheers and thanks.

PowerDevil and ddcutil (which is used by PowerDevil) are the places to look.

I’d start with ddcutil. Use ddcutil CLI commands to see if you can replicate your issue. The VCP feature code for brightness is usually 0x10 but may be different on some monitors.

There’s a chance that Plymouth is adding to this issue.

Plymouth is the boot screen (the three dots) and can often cause issues with booting. Many people (myself included) simply remove Plymouth completely even if it’s not causing a problem; because sooner or later, it probably will.

Plymouth has close ties to boot processes so there is a certain procedure to follow when removing it (not as simple as uninstalling a package).

See the following link under the heading of REMOVAL:

If this does not solve the problem, it will at least remove Plymouth from the equation, in the meantime.

I hope this helps. Cheers.

I will venture into those and see what I find. Thank you very much.

Thank you very much for responding. If you have read the follow up posts, you would have seen that I have resolved the issue but still interested in investigating how it got affected in the course of my prior actions.

I will also look into Plymouth as you have suggested.

Thank you.

Indeed, and now that your issue is solved, it is customary to mark it as such. Please use the :white_check_mark: under whichever post you feel helped the most; even your own post, if that ultimately solved your issue.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.