Scanning from a printer plugged into a router USB port

My setup is:
Manjaro version 5.15.93-1
GNOME version 43.2
Windowing system: Wayland
Relevant software installed: simple-scanner, sane, sane-airscan, avahi-daemon
Router: Plusnet Hub Two

I have successfully set up my Canon Pixma TS5151 inkjet printer and can print successfully. It is plugged into my router’s USB port, and the printer setup is via port (the router’s gateway address) as a JetDirect-Printer. The drivers are installed for “Canon TS5100 series Ver.5.50” with help from another forum post.

Unfortunately, simple-scanner does not see the scanner. I read the ArchLinux page on SANE. I checked that the printer (at least the Canon PIXMA TS5000 series) is supported, and tried scanimage -L which shows a webcam that’s plugged into the computer:

$ scanimage -L
device `v4l:/dev/video0' is a Noname FHD Camera Microphone: FHD Came virtual device

And with sudo:

$ sudo scanimage -L
device `v4l:/dev/video0' is a Noname FHD Camera Microphone: FHD Came virtual device

I noticed a section on accessing your scanner from a remote workstation, and although it’s being considered from removal, I edited /etc/sane.d/net.conf by adding as the last line. Everything else is commented out in that file. All this did was to make scanimage -L run slower, giving the same results.

Is my setup feasible, and if so, what am I missing?

Give gscan2pdf a try

@jrichard326, thanks for your suggestion. Unfortunately, it makes no difference. I think the problem is at a deeper layer than the front-end application.

This is a wifi connectable printer no? Why run it through the router? Set it up on the network and use it.
My guess is the router is getting in the way of the scanner communicating on the network. Does the router have some sort of configuration tool to set up a print/scan server?

1 Like

I would assume that your router is creating a printer server when recognizing an usb printer. I don’t think that it is aware of the scanner options nor has it a scanner server, at least I have never heard of such a router.

Another option would be if the router supported remote usb in a usb/ip compatible way like described in this wiki article: USB/IP - ArchWiki. In this case you should be able to use your device as if it was connected to your PC.

@eriefisher, it doesn’t work via WiFi because my computer (PC) doesn’t have a WiFi card by design. I thought I wouldn’t need one, so chose a motherboard without one. The PC and printer are wired to the same router.

The router is wireless though right?

@eriefisher, yes the router is wireless

Then I would connect the printer wirelessly to the router then it’s available on the network regardless of wired or wireless.

@eriefisher, I finally understand what you meant in the first place! I now have the printer connected as a wireless device to the router, and I can print to it, still as a JetDirect-Printer but now on However, it’s still not visible as a scanner. I tried adding this IP address to /etc/sane.d/net.conf but no luck. I tried it with gscan2pdf as well. I get the same response as before from scanimage -L

Do you have ‘sane-airscan’ installed. I assume you do but please double check.

pamac install sane-airscan

I’m not currently in Manjaro so unsure of the correct package name but it should be at least something similar.

1 Like

@eriefisher, I got it working by doing the following:

  • opened the firewall: sudo ufw allow 8612/tcp
  • enabled avahi: systemctl enable avahi-daemon
  • started avahi systemctl start avahi-daemon

I’m not sure whether avahi is really needed as I could not stop it (without doing a reboot), but I’m just glad it’s working now. Thanks for all your help - this community rocks!

Reference material is:

@eriefisher, yes I installed sane-airscan before writing this post and mentioned it in the 5th line of the post (relevant software installed). It was definitely needed because I now see:

scanimage -L                                                                                                                     ✔  4m 18s  
device `v4l:/dev/video0' is a Noname FHD Camera Microphone: FHD Came virtual device
device `airscan:e0:Canon TS5100 series' is a eSCL Canon TS5100 series ip=

Good stuff! I’m glad it’s working for you.

Avahi is basically there to discover network sevices such as a scanner. However, if you block it with a firewall your stuck. :upside_down_face: Good luck on your journey.

1 Like

I want to acknowledge @eriefisher as a key to this solution even though the whole solution was partly found through a lot of RTFM and experimentation on my part. So I’m writing another post to give the solution to other readers but referencing the other posts:

  1. An important first step was to connect the printer/scanner to the router as a wireless device rather than plugged into USB - eriefisher
  2. Install sane-airscan; although I’d done so, this is a vital step - eriefisher
  3. Enable and start the avahi daemon, which is the device discovery service - me
  4. Open port 8612 on the firewall so that when the device responds, it can be heard - me
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.