Scanning asking for authentication since 27/11 update

Hi all,

With this update I have a little problem with the scan.
When I run simple scan, it now asks me for a password (authentification) before I can scan.
And even if I cancel the question, I can still scan.

I have successfully launched the CUPS-related commands from the beginning of the post. I have no problem for printing

I am under manjaro stable gnome with an hp printer.

I uninstalled and reinstalled the printer, reinstalled cups. Same problem if I create a new user

Thanking you in advance for your help


Didn’t find any solution. I think i’m going to do a fresh install.


Your OP doesn’t really provide any kind of infomation anyone can go on.


Sorry but i don’t know what kind of information you need.
I didn’t find any people with the same problem. No error message. It’s working before the 27/11 update
Every time asking for password for scanning with simple scan or xsane.

I’ve said what i’ve done

What can i describle?

Did you read the link about providing good information???

I mean, really…you haven’t even said what kind of scanner/printer/mfd device you have. We’re not clairvoyant here.

Ok, i only said hp. It’s a hp 3831. i’m afraid it-'s not a problem of model as it works like a charm

Ive tried to uninstall it, uninstall hplip and reinstall all.
As i said, it ask for password you can click on “cancel” and you can scan but it will ask for it every time
. If i give my password, it will ask for it after the next reboot

check your user group membership

$ groups

add to scanner group

$ sudo gpasswd -a $USER scanner
cartes@cartes-ms7823 Linux 5.4.80-2-MANJARO x86_64 20.2 Nibia
~ >>> groups                                                                   
sys network power lp kvm wheel cartes

~ >>> sudo gpasswd -a $USER scanner                                            
[sudo] Mot de passe de cartes : 
Adding user cartes to group scanner

Same problem but thanks form the time you take

Uninstall and reinstall sane didn’t help
So merlock, if you have an idea, you’re welcome :slight_smile:

Tried to modify udev rules but with no success.

I’m going to install again manjaro and verify that the 29/11 don’t break again scanner

Thanks all

New installation didn’t help. Maybe a little bug somewhere (hplip, cps, sane…?)


Just to share:
I found the solution thanks to the arch wiki.
Since a last update, the installation of the scanner requires a little more manipulation.

Now open /usr/lib/udev/rules.d/49-sane.rules and see if there is there is a line with the vendorID and productID of your scanner. If there is not any, create the new file /etc/udev/rules.d/49-sane-missing-scanner.rules, with the following contents:

ATTRS {idVendor} == “vendorID”, ATTRS {idProduct} == “productID”, MODE = “0664”, GROUP = “scanner”, ENV {libsane_matched} = “yes”

The password is then no longer requested :slight_smile:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.