Scaling issues with proprietary nvidia drivers


Im encountering some problems when trying to switch to proprietary nvidia drivers instead of the free drivers. The reason I want to switch drivers is to be able to make use of an external gpu.

After installing the propietary drivers the scaling of what I can try to describe as the system ui ( e.g. Login screen, system settings, taskbar popout, etc… ) seems to change and appear bigger in the screen. Meanwhile other programs such as firefox do not seem affected by it.

I have tried checking the resolution and scaling settings to make sure they are correct and was not able to fix it.

Here is how it looks. Left one is with proprietary drivers and right one with free drivers.

Details about my system:

System:    Host: peter-pc Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Precision 7510 v: N/A serial: <superuser/root required> 
           Mobo: Dell model: 0M1YNP v: A00 serial: <superuser/root required> UEFI: Dell v: 1.19.3 date: 10/04/2019 
Battery:   ID-1: BAT0 charge: 35.7 Wh condition: 61.1/91.0 Wh (67%) 
CPU:       Topology: Quad Core model: Intel Core i7-6920HQ bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 2449 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 2449 2: 3351 3: 3237 4: 1850 5: 2075 6: 2848 7: 2452 
           8: 1794 
Graphics:  Device-1: NVIDIA GM107GLM [Quadro M2000M] driver: nouveau v: kernel 
           Display: x11 server: X.Org 1.20.8 driver: nouveau unloaded: modesetting resolution: 1: 1920x1080~60Hz 
           2: 1920x1080~60Hz 
           OpenGL: renderer: NV117 v: 4.3 Mesa 20.1.7 

Did you try nvidia settings for setting proper resolution in Nvidia proprietary mode?

After some trying I was able to determine that the problem lies in the DPI that X server is using. After a lot of unsuccessful attempts at fixing it, I uninstalled nvidia drivers and installed the free ones, which broke my systems as SDDM wouldnt launch. Then from a boot drive I chrooted into my system and deleted the xorg settings and reinstalled the nvidia drivers with

    sudo mhwd -i pci video-nvidia-450xx

and somehow once I booted again into linux the dpi was set correctly.

I still have some problems for example my secondary screen ( in this case my laptop screen as I use a external display as primary ) is left with a black background. Windows can still be dragged there, right click works fine, but any panels or taskbar are missing, only displaying black.

Here is a similar post I found with the problem from reddit with other answers, didnt work for me but maybe I just messed up some step:

1 Like

Yes, checked that, at the end the problem was with the DPI setting, managed to solve it, dont know how exactly to be honest but seemed that reinstalling from a boot drive did the trick. Still have other problems with the drivers but the scaling/dpi one seems to be fixed for now.

Yeah, the best way to proceed on Manjaro is through MHWD which often requires uninstalling packages before installing drivers and configs.

In Plasma you can set things per monitor when using Nvidia drivers (it works differently on Intel drivers thou), meaning, right-click on the second screen and set wallpaper or effect again. If you want panels, create new ones on the secondary monitor or if you use latte - copy existing ones. Usually they appear on secondary screen automatically (at least my upper panel with global menu and systray did that).

Thanks will give it a try, but when I tried to create new panels they didnt show up. Will give it another shoot and see if changing the wallpaper does anything as well.

I have hybrid graphics, so I when I use Intel multimonitor setup works flawlessly. When I switch to Nvidia or hybrid mode, various problems start. Since I use laptop and I only occasionally plug in the secondary screen, things are unstable on Nvida and hybrid mode and settings are not remembered, or plasmashell crashes, or things work, but not quite - so plasmashell is somehow corrupted. So what I usually do: I kill plasmashell (in sysguard) and launch it again through krunner. Usually this fixes things and I can set secondary monitor. Sometimes it needs more plasmashell restart attempts.

Maybe if I used multimonitor setup all the time things will behave well, but since I plug it off and on only sporadically, in meantime there are some updates (xorg, drivers, kernels, systemd) that may mess with the saved setting? Generally, many weird things are happening on Nvidia drivers. Maybe you find some workarounds or solutions.

Okay seems that assigning a new background image did work and now I can place panels as well, thanks. Just that now Im back to my original problem of the DPI, at least I know where to look to fix it.

Try xrandr to test out properties and possible settings of each monitor. It’s often that the secondary one has some different properties and thus resolution or scaling is different.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.