SbK Xfce-Compiz 24.0.2

I am very happy to announce the release of SbK Xfce-Compiz 24.0.2.

The watermark is not present in the installed OS.

Both iso’s in this release include:

  1. The 6.6.32 LTS kernel.
  2. Compiz 9 with the rotating cube for virtual desktops, faded windows in the background, wobbly windows, and other effects.
  3. The New KoraSpin-Lime10 icon theme with light and dark versions of the control icons. It is part of the KoraSpin-24.0.2 package that includes all colors in the series.
  4. The new SpinThemeLime13 matching Gtk and Kvantum themes in one package.
  5. The new Usplash-24.0.2 desktop wallpapers. One of them is the background for the grub, desktop, and login screen backgrounds.
  6. A basic Conky with matching color theme.
  7. The menu icon in the dock is the Xfce mouse icon and it is color matched to the other themes.
  8. The iso’s are up to date as of 6/12/2024.
  9. An optional Firefox theme, SbK Dark Lime13, that matches the color scheme is available at Firefox Themes just click on the image in Firefox to install it.

Both iso’s also contain the standard SbK features.

  1. The latest LTS kernel.
  2. A Manjaro stable install that is also AUR compatible. In the full iso there are also a lot of packages used to build packages installed. AUR packages are not supported by Arch or Manjaro.
  3. It is multiarch by default to make running wine games and other 32bit software you may run easier.
  4. The Spins by Kilz signed repository is enabled for SbK project packages.
  5. A signed iso. For information on checking signed iso’s visit Check ISO
  6. Bloatware has been removed (HP printer software and others).
  7. Flat packs and snaps are not installed. The back ends are also not installed but can be installed by the user.
  8. All SbK iso’s contain Manjaro Architect script in case you want to do a custom install. To get any SbK packages like themes, icons, and other goodies you will have to add the SbK Repository after install.
  9. Timeshift autosnap installed. It takes a snapshot before upgrading so any bad upgrades can be easily reversed.

A full and very minimal iso can be found here.

As always comments, questions and suggestions are always welcome. Just post below.


Its been a good day building, the rest of the series should be released today.

Hi Jim,

thanks for keeping up the good work! I’ve got an error with the current upgrade, pamac can not load a file: compiz-
Maybe you find some time to look into it.

Thank you :).


I checked and the file and signature file are in the repository. Just to be safe I removed them and uploaded them again. Its possible that there was some time difference for when each file became live on the server, and you tried to install during that time. That sometimes happens as I have to use free hosting for my small project. Give it an hour from my posting and then try again. You might also try using this pacman command in the terminal.

sudo pacman -S compiz

Thanks for the quick reply!
Did a “pacman -Scc” and after “pacman -Syu”

:: Retrieving packages...
 compiz- is up to date
 Total (  1/500)                             265,7 MiB  83,1 MiB/s 00:03 [########################################] 100%
error: failed retrieving file 'compiz-' from : Maximum file size exceeded
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

The problem is still there…Had problems with the PGP Key in the past days, don’t kno if this is related.

Its possible because packages are signed with pgp keys. Until you get that sorted out you can download it here Download compiz- (Spins by Kilz) then right click on the file and open with software installer.

You may have to reinstall the Sbk key, this page shows how to do that. Repository

Arggh, sorry. Just realized here is the xfce posting but i’m on mate. I think it makes no difference. The problem is compiz, I tried the upgrade without it and had to rollback.

On my notebook i have the same issues. I tried to fix it with “sbksign” and “pacman-key --lsign-key 620BB134B4239576”, no lock so far:
Error: failed retrieving file compiz- from : Maximum file size exceeded

Did you try downloading the file, right clicking on the file and select open with software installer?

You are correct, it doesnt matter if its Mate or Xfce, they both use the same compiz package. I have used the new compiz package to build the Mate-Compiz 24.0.4 release that I will be posting about next, so the fault is not with the package.
I also switched the domain to my backup free hosting to try and pinpoint the problem. If you are still having upgrade issues it likely is your pgp setup.

Manual update worked-

The thing is, the package manager should be solid, but it isn’t. AURs are my problem, i love them anyway. But these keyring/broken db problems kept nagging me several times and sources on the internet suggest different things which did hardly work for me.

It sometimes feels like dancing on the edge of a volcano. Without timeshift, my life wouldn’t be so easy… Anyway, my first arch based system on my main system is still hunky dory.

I am very thankful for the effort a small group puts into it for even smaller group of users. Can i donate a small amount to help stabilize the sitarist?