Samsung SCX-3200 Scanner not working

Hi there guys,
I am running Manjaro with Kernel 6.3.5 (6.3.5-1-MANJARO), and using the Unified Linux Driver (uld_V1.00.39_01.17.tar.gz) I was able to make the printer “part” of my device work but scanner did not succeeded.
Checking scanimage commands I got the following outputs:

 scanimage -L
device `smfp:usb;04e8;3441;Z5ZZBDAB708599X' is a Samsung SCX-3200 Series on USB Scanner
device `xerox_mfp:libusb:003:003' is a Samsung Samsung SCX-3200 Series multi-function peripheral
device `v4l:/dev/video0' is a Noname C922 Pro Stream Webcam virtual device
scanimage -T
Output format is not set, using pnm as a default.
scanimage: sane_start: Error during device I/O

If someone has faced this issue or know something about, I would deeply appreciate some help on this.



Did you try this (SOLVED) Printer/Scanner Samsung SCX-3200 error finding scanner / Newbie Corner / Arch Linux Forums ?

Hi @bogdancovaciu , thanks for replying.
I tried partially.

  • cupsd is already a service on systemd:
$systemctl status cups
● cups.service - CUPS Scheduler
     Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; preset: dis>
     Active: active (running) since Sun 2023-06-04 09:23:44 -03; 7min ago

  • I blacklisted usbcore as pointed by the archlinux thread.
  • /etc/sane.d/xerox_mfp.conf already contained an entry for my device:
#Samsung SCX-3200 Series, Samsung SCX-3205W
usb 0x04e8 0x3441

But no success.

Best Regards.