Samsung g9 5120x1440@240Hz - doesn't work (nvidia rtx3090)

Greetings Folks.
Problem: I dont have an option to go to 240Hz on widescreen monitor on 5120x1440 res. In windows 10 this works.

results of inxi --admin --verbosity=7 --filter --no-host:
Moderator Edit: Info updated as of 12 Nov 2021

  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=62f5d95b-8cbc-4437-a7ac-ec0f5179d88a rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: X299 AORUS Gaming 9 serial: <filter>
  UEFI: American Megatrends v: F8m date: 11/28/2019
  Info: 18-Core model: Intel Core i9-7980XE bits: 64 type: MT MCP
  arch: Skylake family: 6 model-id: 55 (85) stepping: 4 microcode: 2006B06
  cache: L2: 24.8 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 187295
  Speed: 1200 MHz min/max: 1200/4200 MHz Core speeds (MHz): 1: 1200 2: 1201
  3: 1200 4: 1200 5: 1263 6: 1200 7: 1200 8: 1200 9: 1200 10: 1200 11: 1200
  12: 1200 13: 1200 14: 1200 15: 1200 16: 1200 17: 1200 18: 1200 19: 1200
  20: 1200 21: 1201 22: 1200 23: 1200 24: 1201 25: 1222 26: 1200 27: 1201
  28: 1201 29: 1201 30: 1201 31: 1201 32: 1200 33: 1200 34: 1200 35: 1200
  36: 1200
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
  Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: ASUSTeK driver: nvidia
  v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 65:00.0
  chip-ID: 10de:2204 class-ID: 0300
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
  loaded: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 80 s-size: 1626x457mm (64.0x18.0")
  s-diag: 1689mm (66.5")
  Monitor-1: DP-0 res: 5120x1440 hz: 120 dpi: 130048 size: 1x1mm (0.0x0.0")
  diag: 1mm (0.1")
  OpenGL: renderer: NVIDIA GeForce RTX 3090/PCIe/SSE2
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
  Device-1: NVIDIA GA102 High Definition Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel bus-ID: 65:00.1 chip-ID: 10de:1aef
  class-ID: 0403
  Device-2: XMOS JDS Labs EL DAC II type: USB driver: snd-usb-audio
  bus-ID: 3-1.2:4 chip-ID: 20b1:30e0 class-ID: fe01
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
  Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
  port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
  vendor: Rivet Networks driver: ath10k_pci v: kernel bus-ID: 04:00.0
  chip-ID: 168c:003e class-ID: 0280
  IF: wlp4s0 state: down mac: <filter>
  Device-3: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Gigabyte
  driver: alx v: kernel port: 2000 bus-ID: 05:00.0 chip-ID: 1969:e0b1
  class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb
  v: 0.8 bus-ID: 1-13:8 chip-ID: 0cf3:e300 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Device-2: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
  bus-ID: 1-4.3:10 chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
  Report: ID: hci1 rfk-id: 2 state: up address: N/A
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: 3020
  bus-ID: 00:17.0 chip-ID: 8086:2822 rev: class-ID: 0104
  Local Storage: total: 9.12 TiB used: 11.07 GiB (0.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Samsung model: SSD 960 PRO 1TB
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: 4B6QCXP7 temp: 30.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
  model: WDS100T3X0C-00SJG0 size: 931.51 GiB block-size: physical: 512 B
  logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
  rev: 111130WD temp: 38.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 4TB
  size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 4TB
  size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-1: / raw-size: 476.63 GiB size: 468.08 GiB (98.21%)
  used: 11.04 GiB (2.4%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:8
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
  used: 31.8 MiB (33.1%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:5
  Alert: No swap data was found.
  System Temperatures: cpu: 27.0 C mobo: N/A gpu: nvidia temp: 50 C
  Fan Speeds (RPM): cpu: 1170 gpu: nvidia fan: 0%
  Processes: 518 Uptime: 11m wakeups: 0 Memory: 125.51 GiB
  used: 3.67 GiB (2.9%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1211 lib: 330 flatpak: 0 Shell: Zsh v: 5.8
  default: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.08

Results of xrandr

Screen 0: minimum 8 x 8, current 5120 x 1440, maximum 32767 x 32767
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-4 connected primary 5120x1440+0+0 (normal left inverted right x axis y axis) 1mm x 1mm
   3840x1080    119.97 + 239.97    59.97  
   5120x1440    120.00*   59.98  
   2560x1440    239.90   120.00    59.95  
   2560x1080    119.88    60.00    59.94  
   1920x1080    119.88    60.00    59.94  
   1680x1050     59.95  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   640x480       75.00    72.81    59.94  
DP-5 disconnected (normal left inverted right x axis y axis)

from cvt values →

xrandr --newmode "240"  2885.25  5120 5600 6176 7232  1440 1443 1453 1663 -hsync +vsync

but when

xrandr --addmode DP-4 240


X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  43
  Current serial number in output stream:  44

can someone help - how do I get 240Hz?

Dear Friends,
I am on a latest Manjaro as of today and I can’t get more than 120hz on 5120x1440 resolution using nvidia rtx3090. xrandr doesnt help at all. Any ideas suggestions. thanks in advance!

How is it connected? DisplayPort or HDMI? You need a DP 1.4 compatible port and cable for more than 120Hz at that resolution.

Please post your system info as outlined here:

Hi, sorry its Display port and all is working under windows. So cable and monitor support it.
i posted before and since then the only thing i did is to update manjaro to use latest kernel and kde

I just merged the two threads since it included your system info, but then just realized it’s been several months since you posted that. Could you post your inxi -Fazy results again? I’ll merge it into the first post.

EDIT: Current info added to first post.

Try using kwinft instead of kwin, it handles displays differently than kwin does, it’s a beta (or is it alpha?) product though but there’s a chance it might solve ur problem.

ok, i will try. i thought its lack of dsc in nvidia drivers…

kernel 5.13 and version drivers Nvidia is old
can you please add theses kernels

sudo mhwd-kernel -i linux514
sudo mhwd-kernel -i linux515
sudo pacman S-linux514-headers linux515-headers

then reboot press Esc on boot to see Grub , and select in Advanced
kernel514 or kernel515

I have a similar monitor Odyssey Neo G9 and while one could wish to use the hardware to it’s fullest extent it is not always possible using Linux as all development is driven by the dominant operating system. The features will eventually reach Linux.

  Device-1: AMD Ellesmere [Radeon Pro WX 7100] driver: amdgpu v: kernel
  Display: x11 server: X.Org driver: loaded: modesetting
  unloaded: fbdev resolution: 5120x1440~120Hz
  OpenGL: renderer: AMD Radeon Pro WX 7100 Graphics (POLARIS10 DRM 3.42.0
  5.15.1-1-MANJARO LLVM 12.0.1)
  v: 4.6 Mesa 21.2.4

I have tried with xrandr - no effect - so while the monitor supports it appears the driver does not.

xrandr --output DP-2 --mode 5120x1440 --rate 240.00

So I will have appreciate the 120Hz refresh rate and it is an improvement over my previous 60Hz :slight_smile:

its such an unfortunate thing. I cant use my modern hardware with modern graphic to its full on linux. But it woks flawlessly. I am so desperate that i am ready to pay someone to get it fixed! just dont know who.

You can pay me - I won’t give any definitive promise though - the only option is to use nvidia-settings - check the options if 240Hz is available - if available try applying the settings.

If it works - you save the config to a file in your home 20-nvidia.conf.

Then remove the file file /etc/X11/99-mhwd.conf and copy the new config to /etc/X11/xorg.conf.d and reboot.

i tried this - same thing. under 5120x1440 res only option is 120hz

Then there’s nothing you can do.

I just noted the above from your xrandr - I am no expert on this matter - only a code monkey with a patreon.


i tried this solution but still no option to select 240hz on 5120x1440

no its not availale. i tried using xrandr and created new resolution and pushed to xrandr then its gives error saying EIDD is wrong. I also asked around nvidia developer forums and they dont seem to know. common answer is that display stream compression has not been enabled for linux drivers…