Samsung Chromebook Pro - speakers not detected


I’ve freshly installed Manjaro (plasma) on my old Samsung Chromebook Pro (Caroline / Intel m3-6y30) and everything works great except the integrated speakers. Manjaro can’t detect them at all, but when I connect my bluetooth headset, the sound comes out alright. 3.5mm jack doesn’t work though. I’ve tried the solutions suggested on ArchWiki (even though they’re for different boards/chipsets) but haven’t had any luck. I’ve tried looking through various forums as well to no avail, so I’d greatly appreciate any help you could offer.

Attaching my inxi -Fazy output:

  Kernel: 5.15.74-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=99b8a3a3-6529-4938-8c82-caff5916bc35 rw quiet
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Google product: Caroline v: 1.0
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Google model: Caroline v: 1.0 serial: <superuser required>
    BIOS: coreboot v: N/A date: 07/20/2018
  ID-1: BAT0 charge: 5.9 Wh (16.6%) condition: 35.5/39.1 Wh (91.0%) volts: 7.1
    min: 7.6 model: SDI 4352D51 type: Li-ion serial: <filter>
    status: discharging cycles: 142
  Info: model: Intel Core m3-6Y30 bits: 64 type: MT MCP arch: Skylake
    level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x4E (78) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 600 min/max: 400/2200 scaling: driver: intel_pstate
    governor: powersave cores: 1: 600 2: 600 3: 600 4: 600 bogomips: 7203
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 515 driver: i915 v: kernel arch: Gen-9
    process: Intel 14n built: 2015-16 ports: active: eDP-1 empty: DP-1, DP-2,
    HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:191e class-ID: 0300
  Device-2: Silicon Motion 720p HD Camera type: USB driver: uvcvideo
    bus-ID: 1-7:3 chip-ID: 2232:1082 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 2400x1600 s-dpi: 96 s-size: 635x423mm (25.00x16.65")
    s-diag: 763mm (30.04")
  Monitor-1: eDP-1 model: Sharp LQ123P1JX31 built: 2016 res: 2400x1600
    hz: 60 dpi: 235 gamma: 1.2 size: 259x173mm (10.2x6.81") diag: 311mm (12.3")
    ratio: 3:2 modes: 2400x1600
  OpenGL: renderer: Mesa Intel HD Graphics 515 (SKL GT2) v: 4.6 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_soc_skl v: kernel
    alternate: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0401
  Sound API: ALSA v: k5.15.74-3-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.58 running: yes
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-3:2 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 29.12 GiB used: 11.79 GiB (40.5%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: HP model: DF4032 size: 29.12 GiB
    block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
    rev: 0x8 scheme: MBR
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-1: / raw-size: 29.12 GiB size: 28.49 GiB (97.85%) used: 11.79 GiB (41.4%)
    fs: ext4 dev: /dev/mmcblk0p1 maj-min: 179:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 512 MiB used: 329.2 MiB (64.3%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 50.0 C pch: 39.5 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 193 Uptime: 43m wakeups: 33 Memory: 3.73 GiB used: 3.31 GiB
  (88.8%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1143 libs: 334
  tools: pamac Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: yakuake
  inxi: 3.3.22

and for convenience inxi -Aa

  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_soc_skl v: kernel
    alternate: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0401
  Sound API: ALSA v: k5.15.74-3-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.58 running: yes

thank you in advance

Did you try swithing kernels?
You can use system settings > Kernels to install another kernel
and then select that kernel when grub menu popsup to boot into that kernel

Tried installing the 6.something kernel. The device wouldn’t boot, couldn’t even access grub so now I’m waiting for another fresh install to finish. Hopefully the other ones won’t break my system too :confused:

update: I’ve managed to install the 6.0.2-2 kernel without any issues this time but unfortunately it hasn’t solved my speaker issue, and neither has any of the other ones.

So after installing kernel your system was unable to boot?
Did the installation finish sucessfully?

And after successfully installing it, Did you boot into that kernel?

I would recommend that you try installing another LTS kernel and booting it.
You can find LTS kernels list in the linnk below

hi, yea the first time I installed the 6.0.2 kernel it broke my system. After that I reinstalled manjaro and enabled grub menu on every boot so that I’d at least be able to revert to one of the older kernels just in case it broke again, and afterwards installed 6.0.2 again. It’s working alright now, so I have no idea why it broke the first time.

Anyway I’ve tried several of the newer kernels but none of them seems to be able to detect my sound card (cat /proc/asound/cards returns – no soundcards --), which is weird since I can play sound just fine provided it’s through bluetooth speakers or headset. Only the built-in speakers and 3.5mm jack don’t work.

Try to follow this, same sound card not sure it’s the same chromebook, was the top result when searching “arch linux chromebook Intel Sunrise Point-LP HD”: