Samba Unable to create new folder in accessed share

I recently started experiencing a weird issue with SMB shares in Dolphin, note I have not yet tried to access the share via another method.

I access my TrueNAS via SMB on my linux machine as well as a mac laptop and iPhone / iPad. On Manjaro I can no longer create a new folder in any of the SMB shares. Whenever I try to create a new folder I get asked for authentication, if I put in the correct password a new authentication window pops up. No matter how many times I click “OK” a new authentication window pops up. What is really weird is that I can copy/move/delete files to and from the NAS without issue, I can even create a new text file but not a new folder. Prior to the system update I did on 10/5 I was able to access the SMB shares and create folders with no issue.

On Mac and iPhone / iPad I do not have this issue so I can safely rule out any configuration issue with the NAS.

Thanks for any help, I am relatively new to SMB and Manjaro.

The following topic contains some troubleshooting tips.

I would ensure the mountpoint on the client has the right permissions - do not use system folders as base for your mounts - create a separate structure in the root of the filesystem.

Perhaps you can use the part where you script the use the gio mount utility.

Alright if I connect through the CLI I can create a folder without issue so this seems to be related to specifically connecting through Dolphin.

when I run

$ ls /run/user/$UID/gvfs

I get no output at all so I’m not really sure where the share is mounted.

If there is no content in the folder - there is no mounted device.

Dolphin uses some behind the scenes - not directly accessible - kde logic.

There is no KDE equivalent to gio mount which may be a possible explanation to why dolphin has issues.

If you use the mount utility from this topic you will get a folder named SMBLinks in home which holds a symlink to real mount location.

I’ll give that a shot, I did discover that this bug has already been reported for KDE so I may just need to wait for an update to see the expected functionality.