Samba shares not auto populating in KDE dolphin

Hello!

I am using Manjaro KDE on my laptop and want to connect to Samba shares from a Pi running Ubuntu 20.04.

I re-installed Manjaro recently and now I notice those Samba shares do not automatically appear when I click on Network > Shared Folders (SMB) in Dolphin. I have to type in the ip address of the Ubuntu server in the address bar, e.g…
smb://192.168.1.12

Then I can see the Samba shares and I can click in to them.

But I am 99% sure the shares (or maybe it was the names of the machines that the shares reside on?) used to auto-populate in Dolphin just like they do in Windows File Explorer (these day with the help of WSDD).

I read “Using Samba in your File Manager

I have installed these packages:
smbclient, gvfs, gvfs-smb, smb4k

But I do NOT want to install Samba server on my Manjaro laptop so I did not run this command:
pamac install samba kdenetwork-filesharing manjaro-settings-samba

I also read this:
Basic Samba Setup and Troubleshooting and followed instructions in the “Samba Client” section.

I just want to know can Manjaro Dolphin work to auto-populate Dolphin when you click Network > Shared Folders (SMB) with ALL machines on the LAN that are offering Samba shares?

Thank you,

Flex

Manjaro does not provide a special version of Dolphin - this is provided by upstream KDE.

It is impossible to know if you can see all SMB shares as this will depend on your priviliges on the network.

Any and all interaction between your system and the network - with relation to SMB shares - are bound to the capabilites of the smbclient utilities, the permissions on the network and how the networked computers are configured.

Thanks @linux-aarhus

Okay so there are many factors that influence how or if this could work. But is it possible?

Are you familiar with Windows file explorer how the Network Neighborhood populates with other computers on the same local LAN? It used to be thanks to NetBIOS but these days you need wsdd running on Linux machines and this makes them automatically show up in windows file explorer.

Is it possible to get the same thing working with dolphin in Manjaro? Can other machines on the lan announce themselves in dolphin when you click Network > Shared Folders (SMB).

From there I could double click on each and see any samba shares they have? I thought I had this working before I reinstalled Manjaro recently…

Cheers,

Flex

It is 10 years since I worked with Windows network. I know what you are referring to.

I haven’t figured the latest changes to samba as the deprecation of SMB1 has removed those browsing facilities you are referring.

Depends on the SMB server.

Have you tried using Smb4K instead of the built-in KIO method of Dolphin?

It uses the superior cifs, rather than KIO or some abstraction layer.

The process of identifying shares uses NETBIOS. These ports vas exploited by wannacry ransomware and has been exploited by numerous other malwares to propagate across network shares.

The SMBv1 has been deprecated for a long time. I do think you can enable by adding below to smb.conf

 client min protocol = NT1

Therefore you need to know the server name beforehand - then list the available services

smbclient -L <servername>  -U <username>

The same can be achieved in your filemanager (with gvfs-smb installed) CtrlL and enter

smb://<servername>

Which will challenge you for the username and password

Thanks both!

So I need to enable SMBv1 in order to have browsing of the network neighborhood?

Do I add the line:
client min protocol = NT1
… into smb.conf on my Ubuntu server or in my Manjaro client or maybe both?

Will I need to install Samba server in Manjaro to get network browsing in Dolphin?

@winnie
I installed smb4k but when I try to run it then it starts and immediately stops.
I think someone else had the same problem and asked the smb4k developer and got this answer:

With the Samba 4.7 release, the default protocol version has been set to SMB3 by the Samba team.
Unfortunately, Samba’s client library cannot handle it correctly at the moment and browsing the network neighborhood will fail. For this reason, users of Samba 4.7 and above need to add the following setting to the [global] section of the smb.conf file to force Samba to use SMB1 (NT1) and, thus, fix the browsing of the network neighborhood:

[global]
...
client max protocol = NT1
...

I tried putting that in /etc/samba/smb.conf in Manjaro and in Ubuntu then:
sudo service smbd restart
… but still nothing showing in Dolphin > Network > Shared Folders (SMB)
Admittedly I don’t actually have Samba server installed in Manjaro right now so don’t see how smb.conf in Manjaro can be doing anything!

Cheers,

Flex

I simply had to install Avahi on my Ubuntu server for that host to auto-appear in the Dolphin File Manager in Manjaro:

sudo apt install avahi-daemon
sudo systemctl enable avahi-daemon
sudo systemctl start avahi-daemon

I removed any references to SMBv1 (NT1) in smb.conf in Manjaro and in the Ubuntu server and it is working with SMBv3. I never figured out about smb4k, it’s not needed in my case given what Avahi does.

Now in Dolphin when I click Network > Shared Folders (SMB)… hosts on my LAN are auto-populated and I can click in to each to see their Samba shares (this is what I was asking for help about):

Cheers,

Flex

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.