Samba NOT asking for password

Hi All, sorry, I bet this is a simple one but I’ve not figured it out yet.

Fresh install of Manjaro with Cinnamon DE. Set up samba via guide and rebooted per wiki guide.

I am sharing my home dir to several other linux computers on my LAN. I can share via the Nemo gui but I have two cases that don’t work as expected:

  1. If I share without having set an smb password (smbpass) for my user then the client nemo closes when I attempt to connect. I take that as a fail. Not a great behavior but OK I guess? Seems it should ask for credentials again?

  2. If I do create an smb password (smbpass) for my user then on the client side I am not asked for a password at all.

Then, just to keep it interesting on the client side, if I disconnect from my share and attempt to reconnect for some strange reason nemo opens the text editor which says it’s a directory…??

Very confused. Have tried manually setting up smb.conf but something is just not right with password checking…



What guide did you use so there is a reference to what you have done?

Well, if you haven’t run smbpasswd -a USERNAME you haven’t actually added any users.

Hi, I tried to include it but it’s not allowing me to post it in here. Because I’m new maybe?
It’s the Manjaro wiki: Using Samba in your File Manager

I had started to set up samba directly then backed it out and deleted all files then followed the instructions in the wiki which seems pretty straightforward.

You mean this one? Using Samba in your File Manager - Manjaro
Well, that says to install and then run smbpasswd -a USERNAME. I don’t know what questions you got from installing it, the wiki doesn’t mention anything about setting up a share but it does mention setting up config files.

Check /etc/samba/smb.conf and see what you are sharing if you are sharing anything?
That should be it, adding a user and creating a share and it should work.
Oh yeah, make sure the user is added to the group sambashare.

If not, you have to provide a little more info on what fails and where.

Yes, that’s the guide.

Once completing the guide I used Nemo to select my home folder to share.

I discovered that nemo creates the share in here vs in smb.conf:

Looking in there I have this:


Also noting that nemo does not ask you about requiring a password. I assume its assumed but only asks two questions neither of which appear to impact the behavior I’m trying to address.

  1. Allow others to create and delete files in this folder
  2. Guest access

I found a place that says I can set usershare-acl=myuser:F but when I do that an restart smb my share is not listed anymore…

Try changing the password, if you still get logged in w/o password prompt there is something wrong.

Thank you @bedna.

I think that gave me the clue I needed. )

Yes, changing the password does force me to use it. …So I suspect that what was throwing me off was that the nemo client was saving/reusing the password even when I would change the name of the share. …And therefore the password saved corresponds with the device and not the shared folder name… Yes, I think that may be it :slight_smile:

As for the other odd client side Nemo behavior… Not so concerned anymore provided the above solution sticks. :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.