Samba AD Daemon fail to start

I type systemctl --type=service
The result about SAMBA:
samba.service loaded failed failed Samba AD Daemon
smb.service loaded active running Samba SMB Daemon

But I can read the share folder from other PC.
My smb.conf is default.

So, anyone can help me, please.

1 Like

Is your machine part of an Active Directory domain?

If not, Do you just want to get rid of this warning?

if yes:

sudo systemctl disable samba.service


The samba daemon on your machine doesn’t have anything to do with mounting/looking at samba shares from another machine.
The daemon is used to provide services from your machine to others.

1 Like

Thanks for that! When I started to write the answer, that’s what I wanted to end with, but by that time, I forgot to mention he doesn’t need it so it’s safe to disable it…


1 Like

So, I just ingore it?

If you want to use it as an Active Directory Controller, you may want to configure it properly.
If not (and this is much more likely), just disable it like @Fabby suggested.

1 Like

I dont want to use it as an Active Directory Controller, so I disable it, no"failed" now, thanks!

And thanks @freggel.doe too!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.