Saitek Combat Rudder Pedals detected by KDE, but not by evdev-joystick

I have been pulling my hair out on why games cannot see these pedals. I go into calibration in KDE Settings, and they show up just fine. Pull up a game? Game doesn’t see them. Pull up Wine Control Panel? Pedals aren’t seen there either.

KDE sees them as the following:
Saitek Saitek Pro Flight Combat Rudder Pedals (/dev/input/js2)

js1 and js0 are my HOTAS Warthogs.

But evdev-joystick only lists the following other two joysticks:

evdev-joystick --l

Any ideas on how to fix this?

Edit: They used to work in Manjaro and games used to be able to use them. No longer. They calibrate fine though. I think this has something to do with the transition to evdev, but I could be wrong.

Digging deeper, I decided to remove joydev from the kernel temporarily. I have confirmed KDE is using joydev to see joysticks as it cannot see anything anymore.

I confirmed Wine still sees my HOTAS controllers, but it still can’t see my Saitek. So it is clear Wine is using evdev for joystick support.

Determined that it fully revolves around evdev now as the culprit.

Anyone know how to get evdev to see joysticks it currently doesn’t see?

Further digging, the /dev device permissions are not the same as the Thrustmaster gear. Any recommendations on how to fix this? If I unplug the device and plug it back in, or reboot for that matter, are the permissions going to be retained?

Event 6 is my throttle (which works) and event 7 is my rudder pedals (which doesn’t work). What is the + permission? Any help here would be appreciated:

crw-rw----+ 1 root input 13, 70 May 23 08:07 event6
crw-rw---- 1 root input 13, 71 May 23 08:07 event7

Whatever that is is the main difference between the two I think.

Still no joy on this one… Pun intended. Anyone got a clue on why joydev would see these rudder peddles and evdev sees them but marks them automatically as restricted to root?

Nevermind… Ran evdev-joystick as root and it still doesn’t show up. Only joydev can see and use these rudder pedals.


No device specified, trying to scan all of /dev/input/event*
Not running as root, no devices may be available.
Available devices:
/dev/input/event10: Thrustmaster Throttle - HOTAS Warthog
/dev/input/event3: Thustmaster Joystick - HOTAS Warthog
/dev/input/event9: Saitek Saitek Pro Flight Combat Rudder Pedals
Select the device event number [0-10]:

Had to add a udev rule under /etc/udev/rules.d for the pedals so that normal users can use them. Seems to be evdev is broken if I have to do this.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.