RX 6800 + Manjaro, some textures and elements not rendering correctly in some games

Hi all,

I have a weird problem I’m hoping some of y’all can shed some light on. I’ve had the RX 6800 for about 3 weeks now. Everything seems to be working fine. I updated to kernel 5.10.2, and am running mesa git 21.0.0, Linux firmware 20201218.r1803, and llvm 11.0.0-4.

Some games are working well. I have played hours on Cyberpunk 2077 and Overwatch without issues.

However, I am having issues with some other games. GTA V is not rendering the world correctly anytime I walk outside of a building. While inside buildings everything is as expected.

However, as soon as I head outside, it looks like this:

I also have an issue with Lost Ember. The ground is all black, it does not look like this in Windows.

Is it possible I am missing packages? I have tried different versions of proton and that does not seem to be the issue. Any suggestions for troubleshooting are appreciated.

Same Problem here with a 6800xt. Running:

  • Kernel 5.10.12
  • mesa 21.1 dev
  • firmware 20210119.r1813

I run GTA V under Lutris (got the Rockstar launcher version) with dxvk.

Had the same hardware setup except an old Radeon 7870 until I got my 6800xt. Everything was running fine (except horribly low fps, of course) with that one, so I think it can be narrowed down to the driver - I was using AMDGPU with both.

Out of desparation I already tried older lutris runners and dxvk versions. I also tried some of the debug options RADV provides - all without success.

I went back to the intro scene to get reproducable tests. The bug occurs rarely indoors. If it does, moving slightly can switch from correct to faulty display.

In outdoor scenes the bug occurs far more often and can’t be solved by slightly moving the character. When switching back to dx10 I get a similar “all white” image like knishofdeath got.

When turning around the environment seems fine but I rather get faulty shading on the character. It seems like there is something wrong with (global) illumination and reflections. But this still does not explain the bug occuring indoors.

(i had screenshots added but the forum does not allow me to post images…)

I am rather new to the linux community and don’t really know where to look for support for this. Is this a driver issue? If so: kernel or mesa? Maybe something with wine or dxvk?
Although this is a quite specific bug (only occuring with certain hardware and games) It would be nice if someone could point out a direction.

Also I am still struggling with providing logs. I tried capturing the the log output from lutris once (but messed up saving it) and could not find anything useful. I also doubt one could find anything there since nothing is crashing.

Solution seems to use LLVM instead of ACO. To do so use the environment variable RADV_DEBUG=llvm