Runtime error: terminate called after throwing an instance of 'libaudiostream::AudioException'

I’m trying to compile and run aldo on my Pinebook Pro. Everything worked well on my ARM64 Pinephone under Mobian OS, but I’m getting a runtime error on my Pinebook Pro with Manjaro:

terminate called after throwing an instance of 'libaudiostream::AudioException’
what(): std::exception
Aborted (core dumped)

In the runtime setup menu, I setup aldo to use the default sound device, which is “default”:

Soundcard device name/file [default]:

The default worked under Mobian on my Pinephone.


I’m running the latest stable Manjaro on my Pinebook Pro and it is up to date. Any suggestions are most appreciated.


I have libao 1.2.2-5 (required) and alsa-OSS 1.1.8-4

I discovered that aldo works on my Pinebook Pro when executed with root permissions (“sudo aldo”) so, on whim, I added myself to the audio group in Manjaro to no avail.

My Mobian system has audio and pulse group membership but there is currently no pulse group on my Manjaro system. What is the proper way to correct this permissions error?