Running ssh server

Hi,
I’m trying to connect to my Manjaro via ssh, using my iphone. No need for ssh-keys for now. Both are in the same wifi.

If I run sshd -t, I get sshd: no hostkeys available -- exiting.
If I run sudo sshd -t no output

Then I started the servive via sudo systemctl start sshd
If I check the status, it shows “active (running)”
In my /etc/ssh I have a bunch of key-pairs there

On my iphone I first tried installing the “ish” app. There, I can apk add the openssh package. But if I try ssh user@ip I get connection time out. If I try to ping the ip, “Host is unreachable”

I also tried using the “blink” app. I also get connection time out.

Is there anything I should do in my modem to allow connections? Or I am missing some other configuration in my Manjaro?

Eventually I got it working:

I initially tried to add a firewall rule via the GUI for ufw. It had a simple configuration for ssh…

So I deleted this rule, and used instead this command:

sudo ufw allow from <ip-address> 

And now it works (tested it from the blink app)