Running qalculate-qt on KDE plasma gives "undefined symbol" error

Linux 5.15.133-1-MANJARO #1 SMP PREEMPT Sat Sep 23 10:10:02 UTC 2023 x86_64 GNU/Linux

I first installed manjaro with cinnamon on my PC (intel core2duo, 4GB RAM) and then installed qalculate-gtk. it was working fine.

Then I installed KDE Plasma along with cinnamon and then logged in again in plasma.

But now qalculate does not run. I installed qalculate-qt again and tried to run it. But I still get the error:
qalculate-qt: symbol lookup error: qalculate-qt: undefined symbol: _ZN10Calculator33setConciseUncertaintyInputEnabledEb

How do I fix this?


oh, actually I’m using qalculate-gtk-nognome on KDE - partly because the QT variant wouldn’t let me remove individual history items without doing a context click (GTK can arrow and shift-delete to remove selected items) if I remember.

However, I just installed qalculate-qt and there are no errors, so I’m sorry - no dice.

However, I would say it’s a pretty bad idea to install KDE ‘alongside’ Cinnamon. I tried Cinnamon before I used KDE, and it didn’t play nicely until I sorted out a fresh install.

So, first action, ensure you have a nice rsync backup on another drive containing all your hidden configs in home… and think about a fresh install of KDE and import settings which are useful.


I just installed it, specifically to test it:

$ pamac install qalculate-qt --no-upgrade
Resolving dependencies...
Checking inter-conflicts...

To install (1):
qalculate-qt  4.8.1-1    extra

Total installed size: 3.8 MB

Apply transaction ? [y/N] y
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: Mirdarthos (mirdarthos)
Checking keyring...                                                                                                                                                                                                                                     [1/1]
Checking integrity...                                                                                                                                                                                                                                   [1/1]
Loading packages files...                                                                                                                                                                                                                               [1/1]
Checking file conflicts...                                                                                                                                                                                                                              [1/1]
Checking available disk space...                                                                                                                                                                                                                        [1/1]
Installing qalculate-qt (4.8.1-1)...                                                                                                                                                                                                                    [1/1]
Running post-transaction hooks...
Arming ConditionNeedsUpdate...                                                                                                                                                                                                                          [1/4]
Updating icon theme caches...                                                                                                                                                                                                                           [2/4]
Checking for .pacnew and .pacsave files...                                                                                                                                                                                                              [3/4]
Updating the desktop file MIME type cache...                                                                                                                                                                                                            [4/4]
Transaction successfully finished.

I added the --no-upgrade argument so as not to upgrade Chromium and Vivaldi from the AUR, which would have made this a substantially bigger download.

And tested it:

$ qalculate-qt

As you can see, I had no problems. This leads me to think you have a partially updated system and you should upgrade your whole system first.

1 Like