Running OBS on Manjaro Linux

Respected forum viewers,
I want to run OBS-Studio on Manjaro. I have dual booted Windows and Manjaro. Don’t know the reason but OBS-Studio doesn’t work at all. It works flawlessly on Windows but on Linux, it just crashes with an error “Failed to initialize GPU
…bla bla bla”. And not only Manjaro, I have tried dozens of distributions but this just doesn’t seem to work. I just can’t figure out why OBS-Studio works flawlessly on Windows but doesn’t even launch on Manjaro.
Also I read a workaround on OBS studio discussion forum by editing OBS-Studio file with something like LIBGL_. …bla bla bla (I don’t remember correctly) but I tried that also. Although OBS studio launches this time, it just takes 25% CPU on idle & 70-80% on doing just a simple display capture whereas on Windows, the CPU usage is far more less like 3-5% and that too while recording heavily with video capture, audio input, etc.
(My Laptop is quite old [10 years tbh :sweat_smile:]. It’s Dell Vostro 3300 with i5 m520 @2.40ghz. But still it works flawlessly as my daily driver. I am just in Class 10th so everything works for me on this old machine. Will go for a new one after 2-3 years when I’ll step into college).
Kindly help me out with this so that I can easily use OBS on Linux as well.
Thanks in Advance to the Community…:smiley:

Welcome to the forum! :wave:

Post the output of inxi --full --admin --verbosity=7 --filter --no-host and specify the “Failed to initialize GPU …bla bla bla” error message: you can also launch it from Terminal.

1 Like

Yeah Sure. The output for the command that you told is as follows:

  Kernel: 5.13.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=eaff4e33-e200-46ad-8b59-ab16cf0cb96e rw quiet 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: plank wm: kwin_x11 vt: 1 
  dm: SDDM Distro: Manjaro Linux base: Arch Linux 
  Type: Portable System: Dell product: Vostro 3300 v: A10 serial: <filter> 
  Mobo: Dell model: N/A v: A10 serial: <filter> BIOS: Dell v: A10 
  date: 10/25/2010 
  ID-1: BAT0 charge: 2.7 Wh (19.9%) condition: 13.6/33.4 Wh (40.8%) 
  volts: 16.3 min: 14.8 model: SMP DELL 93G7X05 type: Li-ion 
  serial: <filter> status: Charging 
  RAM: total: 7.57 GiB used: 1.55 GiB (20.5%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5 M 520 bits: 64 type: MT MCP 
  arch: Nehalem family: 6 model-id: 25 (37) stepping: 2 microcode: 11 
  cache: L2: 3 MiB bogomips: 19162 
  Speed: 1197 MHz max: 1197 MHz boost: enabled Core speeds (MHz): 1: 1197 
  2: 1197 3: 1197 4: 1197 
  Flags: acpi aes aperfmperf apic arat arch_perfmon bts clflush cmov 
  constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts ept est 
  flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce mmx 
  monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pclmulqdq pdcm pebs pge 
  pni popcnt pse pse36 pti rdtscp rep_good sep smx ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc vme vmx vnmi vpid 
  xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; 
  SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Core Processor Integrated Graphics vendor: Dell 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0046 class-ID: 0300 
  Device-2: Microdia Laptop_Integrated_Webcam_2M type: USB driver: uvcvideo 
  bus-ID: 1-1.4:5 chip-ID: 0c45:6481 class-ID: 0e02 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (ILK) v: 2.1 Mesa 21.2.1 
  direct render: Yes 
  Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.15-1-MANJARO running: yes 
  Sound Server-2: sndio v: N/A running: no 
  Sound Server-3: JACK v: 1.9.19 running: no 
  Sound Server-4: PulseAudio v: 15.0 running: yes 
  Sound Server-5: PipeWire v: 0.3.35 running: yes 
  Device-1: Broadcom BCM43224 802.11a/b/g/n 
  vendor: Dell Wireless 1520 Half-size Mini PCIe Card driver: wl v: kernel 
  modules: bcma port: f000 bus-ID: 12:00.0 chip-ID: 14e4:4353 
  class-ID: 0280 
  IF: wlp18s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: e000 bus-ID: 13:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp19s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB 
  driver: btusb v: 0.8 bus-ID: 2-1.1:3 chip-ID: 0a12:0001 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 521.66 GiB used: 19.31 GiB (3.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 model: Consistent CTSSD240S3 size: 223.57 GiB 
  block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD 
  serial: <filter> rev: 6A0 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST9320423AS 
  size: 298.09 GiB block-size: physical: 512 B logical: 512 B 
  speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: SDM1 
  scheme: MBR 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 110.35 GiB size: 108.06 GiB (97.92%) 
  used: 19.31 GiB (17.9%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: eaff4e33-e200-46ad-8b59-ab16cf0cb96e 
  Alert: No swap data was found. 
  ID-1: /dev/sda1 maj-min: 8:1 size: 1000 MiB fs: ntfs 
  label: System Reserved uuid: 069AD2F09AD2DAEF 
  ID-2: /dev/sda2 maj-min: 8:2 size: 112.24 GiB fs: ntfs label: N/A 
  uuid: C48EF6348EF61E9C 
  ID-3: /dev/sdb1 maj-min: 8:17 size: 298.09 GiB fs: ntfs 
  label: Surya's Drive uuid: CAA68505A684F2ED 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900 
  Hub-3: 1-1.1:3 
  info: Broadcom BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth) ports: 3 
  rev: 2.0 speed: 12 Mb/s power: 94mA chip-ID: 0a5c:4500 class-ID: 0900 
  Device-1: 1-1.1.1:6 info: Dell Integrated Keyboard type: Keyboard 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 2mA chip-ID: 413c:8161 class-ID: 0301 
  Device-2: 1-1.1.2:7 info: Dell Integrated Touchpad [Synaptics] 
  type: Mouse driver: hid-generic,usbhid interfaces: 1 rev: 2.0 
  speed: 12 Mb/s power: 2mA chip-ID: 413c:8162 class-ID: 0301 
  Device-3: 1-1.2:4 info: Realtek RTS5138 Card Reader Controller 
  type: Mass Storage driver: ums-realtek interfaces: 1 rev: 2.0 
  speed: 480 Mb/s power: 500mA chip-ID: 0bda:0138 class-ID: 0806 
  serial: <filter> 
  Device-4: 1-1.4:5 info: Microdia Laptop_Integrated_Webcam_2M type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 168mA 
  chip-ID: 0c45:6481 class-ID: 0e02 
  Hub-4: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-5: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0020 class-ID: 0900 
  Device-1: 2-1.1:3 
  info: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: Bluetooth 
  driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA 
  chip-ID: 0a12:0001 class-ID: e001 
  System Temperatures: cpu: 55.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
  Processes: 221 Uptime: 14m wakeups: 4 Init: systemd v: 249 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1190 lib: 340 
  Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

And for specifying the output, it states:-
Failed to initialize video. Your GPU may not be supported, or your graphics drivers may need to be updated.
And if I go for the workaround of editing desktop file of OBS:-
By typing Exec=env LIBGL_ALWAYS_SOFTWARE=1 obs
Then it finally launches… But on idle the CPU usage of OBS fluctuates between 15-25% and just a simple display captures takes the CPU to a whopping 75%. I don’t know why. Whereas on Windows its far less.
Hope that this Problem gets solved…

It’s possible that a better experience is achievable with this package from the AUR:

pamac build libva-intel-driver-g45-h264 

As per the arch wiki this is experimental, but you can try it and see. Make sure to select x264 in encoder in OBS settings.

I tried that too but to no avail. The CPU usage isn’t decreasing at all. And Even with such high CPU usage of 70-80%, the output video is just worse…It’s recording at 4-5 fps hardly and the quality is also bad.

Any update regarding this issue? Or you have suggestion for any other distribution that has proper drivers which will make the Integrated Graphics of my old Processor work with OBS? Cause if my hardware would have been incapable then OBS wouldn’t run on Windows also. Instead, it works flawlessly on Windows but not on a single Linux Distribution I tried…

Alternatively, snapd can be installed from the command line:

sudo pacman -S snapd

Once installed, the systemd unit that manages the main snap communication socket needs to be enabled:

sudo systemctl enable --now snapd.socket

To enable classic snap support, enter the following to create a symbolic link between /var/lib/snapd/snap and /snap:

sudo ln -s /var/lib/snapd/snap /snap

Either log out and back in again or restart your system, to ensure snap’s paths are updated correctly.

To learn more visit ( )

try getting automatic driver updates from hardware config section in kde, reboot and try

Yeah, I had an issue when I had NVENC encoder set by default and it didn’t wanna work (my hardware doesn’t support it).
If I recall correctly, x264 uses the CPU, so that may be the reason, why there is suddenly bigger CPU usage…

Updated drivers are also very important, as well as updated kernel. It often solves problems automagicaly…

this will solve it hopefully. just go to settings → output → then change encoder in streaming and recording to software