Running an older version of a Desktop Environment

I know Deepin is not supported in Manjaro anymore but I think this applies to all Desktop Environments.

Currently Deepin is in development and has issues, so I would like to still use the old version that I have, but also update all my other apps.

I tried updating everything except the deepin packages and my deepin broke, only part of it was working (it was weird).

Similarly, after reverting to an image (I made one, since I had a feeling it might not work) I updated KDE (synced: pacman -S plasma) and now it crashes and sends me right back to the login screen whenever I try to login with plasma.

Moreover, it seems like this is the case with many applications. I tried downgrading or upgrading them with downgrade (I did override ALA with DOWNGRADE_FROM_ALA=1) and they won’t run until I put back the same one.

  1. I was wondering why this is the case?
  2. How can I run an older version of the a Desktop Environment?
  3. And if this isn’t possible, at least how can I make plasma run on my older version of manjaro again as now it’ll just install the new version of plasma that crashes? (However, this is the last resort because I would definitely prefer to update.)

Because the underlying libraries that the desktop environment uses, gets updated to new versions, while the DE is looking for the old versions.

Install it the way you want. Don’t update or install anything new.

That does make sense.

I can’t install it on an updated system?

You can’t easily. The source for the older version of deepin was archived by the deepin team and without patches it doesn’t run with the current software in Manjaro/Arch.

If you want to run it, you would have to work through building it and developing patches to make it work with the newer libraries in Manjaro.

This is probably fixable and trying to downgrade plasma is likely not the best solution.


I see, I think I understand. That does make sense.

How can I do it. Because at this point I think this is the route to take (the other being rather hard).

First, you need to update your whole system.

What you did, pacman -S plasma without a fully updated system will usually break your system because you are creating a partial update scenario.

If you want to update plasma, you should do it as part of the normal system update process with sudo pacman -Syyu

If you are trying to install plasma on existing system running deepin, be aware that deepin and plasma don’t work together very well.

1 Like

Yes, it is a partial upgrade so it does make sense that it’s kinda causing problems. Nothing else was updated so I just decided to downgrading each plasma package with downgrade <<package>> and entering the right version for my system. It works now!

Ya Deepin does conflict with kde but I don’t have the deepin-kwin installed as it highly in development and doesn’t work that well. So I’m just using the deepin’s old window manager which doesn’t really have problems with kde.

It is pretty rough manually going through each package though, so is there a way to downgrade a group of packages like plasma or kde-applications all at once? Like going to a previous repository set or something?