Runescape "NXT client" ERROR: PGP signature of 'Release' could not be verified

My fix

Iv made this post for the value of the community.

When downloading the NXT client from the AUR repository in pacman, i was having problems with the build not working.

this is the error message

ERROR: PGP signature of 'Release' could not be verified

gpg: Signature made Wednesday 5 August 2020 05:31:32 PM IST

gpg: using RSA key AAC9264309E4D717441DB9527373B12CE03BEB4B

gpg: Can't check signature: No public key

==> ERROR: A failure occurred in prepare().

I read this post on new Manjaro form to understand what PGP keys are for and how they work

AUR package fails to verify PGP/GPG key: “unknown public key”, “One or more PGP signatures could not be verified! (Sorry i cant post links yet, Just copy and past to find in search bar)

then seeing if there was any clues with other people having the same problem with this specific build
here

(again cant post links yet just go to aur.aurchlinux user repository site and search Runscape-launcher, looking for NXT one)

after realizing what i needed to do as i am still learning to operate manjaro XFCE to its fullest and learning as i go along i found that all you need to do is

open your terminal and paste this command

gpg --keyserver hkps://keyserver.ubuntu.com --recv-key AAC9264309E4D717441DB9527373B12CE03BEB4B

This is from the arch linux site just copy and paste Runescape-launcher in to the search and your looking for the NXT build when you find the correct one you will see a pinned post advising to remember to run this command upon first usage, or something along them lines, overtime the key may change but not sure check on the arch site if it is not working.

This worked for me straight away

Hope this helps someone out there struggling to install Runescape NXT client, this is the only RS3 (not old school) client i have managed to get to work so far, other old school clients seem to work okey i have tried this one for old school client “unix-runescape-client”

1 Like

Good that you make a thread like this. This will be helpful to other people who might experience issues!