Run-time dependency unity found: NO (tried pkgconfig and cmake)


I’m trying to build from source the ShutdownScheduler app but I can’t seem to resolve the unity dependency. After meson build I get this:

WARNING: CMake Toolchain: Failed to determine CMake compilers state
Run-time dependency unity found: NO (tried pkgconfig and cmake)

src/ ERROR: Dependency "unity" not found, tried pkgconfig and cmake

Where can I find the unity dependency?

Thank you all!

See Unity3D - ArchWiki

EDIT: Or not. See my post below.

Hi @Yochanan, thanks for your reply!

I’ve installed UnityHub from AUR but it doesn’t seem to help. Am I missing something?

I think the requirement is the desktop manager Unity and not the game engine.

I didn’t find it in the repos or the AUR.

1 Like

That would be libunity then. It’s usually broken as it’s deprecated and won’t build with recent versions of vala.


Uuh I see, so no way of getting the app built I guess…
Thank you for helping out @Yochanan and @mithrial !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.