Run/initramfs error when system boots

Been getting this message on boot for the last few days

cp: cannot create directory'/run/initramfs/': No such file or directory

The system boots fine and everything works ok, I think its related to this bug report

but its out of my knowledge range unfortunately

Generated on 2022-05-04 12:21:1651663311

#################### inxi -Fxzc0 ########################

System:
  Kernel: 5.17.5-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0 Desktop: Cinnamon
    v: 5.2.7 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Micro-Star product: GS72 6QE v: REV:1.0 serial: <superuser required>
  Mobo: Micro-Star model: MS-1775 v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends v: E1775IMS.111 date: 04/12/2016
Battery:
  ID-1: BAT1 charge: 40.0 Wh (100.0%) condition: 40.0/59.9 Wh (66.8%) volts: 12.3 min: 11.1
    model: MSI Corp. MS-1775 status: full
CPU:
  Info: quad core model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S rev: 3 cache:
    L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 852 high: 900 min/max: 800/3500 cores: 1: 878 2: 814 3: 841 4: 900 5: 896
    6: 826 7: 815 8: 853 bogomips: 41621
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel HD Graphics 530 vendor: Micro-Star MSI driver: i915 v: kernel bus-ID: 00:02.0
  Device-2: NVIDIA GM204M [GeForce GTX 970M] vendor: Micro-Star MSI driver: nvidia v: 510.68.02
    bus-ID: 01:00.0
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: modesetting,nvidia gpu: i915
    resolution: 3840x2160~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 22.0.2 direct render: Yes
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.17.5-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Rivet Networks Killer Wireless-n/a/ac 1535 driver: ath10k_pci v: kernel bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Micro-Star MSI driver: alx
    v: kernel port: d000 bus-ID: 04:00.0
  IF: enp4s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IF-ID-2: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb v: 0.8 bus-ID: 1-10:4
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
    hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 1.14 TiB used: 747.56 GiB (63.9%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB temp: 41.9 C
  ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB
Partition:
  ID-1: / size: 216.37 GiB used: 93.36 GiB (43.1%) fs: ext4 dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: partition size: 17.07 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 49.0 C pch: 66.0 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 295 Uptime: 21m Memory: 15.5 GiB used: 4.03 GiB (26.0%) Init: systemd Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: 1654 Client: Cinnamon v: 5.2.7 inxi: 3.3.15


please try this first and report after reboot

sudo mkinitcpio -P
sudo update-grub
2 Likes

Did you modify (or not merge) the /etc/mkinitcpio.conf file?

1 Like

I noticed the error after installing vir-manager/qemu and setting up windows 10 to run in vir-manager, I sudo systemctl enable --now libvirtd to enable libvirtd to run on boot but don’t think that is the issue

Edit

I’ve notice a hook in the mkinitcpio.conf

HOOKS=(base shutdown udev autodetect modconf block filesystems keyboard fsck)

which would tie in with the bug report

That was my first port of call but the error still pops up on boot

@sawdoctor

$ cat /usr/lib/initcpio/install/shutdown    
#!/bin/bash

build() {
    add_binary cp
    add_binary lsblk
    add_binary findmnt
    add_binary umount
    add_file "/usr/lib/initcpio/shutdown" "/shutdown" 755

    add_runscript
}

help() {
    cat <<HELPEOF
This hook copies the contents of the initramfs into /run/initramfs for reuse
on shutdown. This is needed when you have /usr mounted on a separate partition.
HELPEOF
}

# vim: set ft=sh ts=4 sw=4 et:

Read the help text and you will know that the shutdown hook belongs to the end of the hock array. :wink:

Saw this error pop up after the previous testing update and it still exists after today’s update. System seems unaffected.

My hooks line for comparison: (base udev autodetect modconf block filesystems keyboard fsck shutdown)

2 Likes

Same situation for me, booting 5.17 or the fallback option both boot successfully.
/etc/mkinitcpio.conf :

HOOKS="base udev autodetect modconf block keyboard keymap plymouth filesystems shutdown"

Edit: no difference when booting a 5.15 kernel.

1 Like

Remove shutdown hook to solve.

2 Likes

Thanks for the update, really appreciated. Its only an annoying message but nice to get rid of it

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.