Run console-getty with plymouth-gdm

When I enable console-getty and reboot, plymouth brings up plymouth-gdm (or is it gdm-plymouth), and then a couple of seconds later vt1 turns into a blank screen. I can then ctrl+alt+f2 and then ctrl+alt+f1 and gdm will launch again of vt1 and be fine. Can I correct this behavior so getty and gdm launches correctly?

I honestly don’t want getty do do anything unless I switch to vt2, and I thought the default config would do that.

replace it with gdm … remove plymouth from /etc/mkinitcpio.conf hook line, then run
sudo mkinitcpio -P
sudo update-grub

1 Like

Sorry, I’m not using grub, I didn’t think to include this info. I still want plymouth, I just don’t want this weird behavior where gdm has started and then getty turns around and blanks vt1. I’m using systemd boot. I could easily gank sd-plymouth but then it wouldn’t start or early enough? presumably, would cease to run at all.

MODULES="crc32c-intel i915"



HOOKS="base systemd sd-plymouth autodetect keyboard keymap sd-vconsole block sd-encrypt modconf filesystems"

title	Manjaro Linux 5.10
linux	/vmlinuz-5.10-x86_64
initrd	/intel-ucode.img
initrd	/initramfs-5.10-x86_64.img
options	root=UUID=8e129ee4-9e55-4558-b4ea-33eb08f6b95e rw rootflags=subvol=/@ cryptdevice=UUID=d14ab16d-26ae-4dc1-933c-fa516232997c:cryptroot elevator=kyber rootflags=subvol=@ quiet splash apparmor=1 security=apparmor udev.log_priority=3 threadirqs