RTX 3080 Ti (laptop) + proprietary drivers = lights out

Hey everybody! Manjaro 22 is struggling with my new laptop’s RTX 3080 Ti. Dual-booting with Windows 11. Here are the PC’s specs: ASUS ROG Strix Scar 17 SE G733CX-LL016W ab € 4999,00 (2023) | Preisvergleich Geizhals Deutschland

My experiences so far:

  1. Run live USB with proprietary drivers > hangs on boot

  2. Run live USB with open-source drivers > boots, installation works

  3. Reboot, install Nvidia drivers with command “sudo mhwd -a pci nonfree 0300”, reboot > nvidia-settings shows no sign the graphics card. Screenshot:

  1. Install all software updates, including one for the Nvidia drivers, reboot > hangs on boot after message, “loop0: detected capacity change from 0 to 8”

  2. Reboot, select advanced options from boot loader, then option “fallback initramfs” > boot splash shows for a moment, then: black screen with white cursor (non-blinking) in top left corner

This is with kernel 6.1.12.

I’m a Linux Mint user trying out Manjaro for the first time, since the Mint live USB won’t even begin booting on this machine. So I’m completely at a loss here. If this was Mint, I’d try Ctrl+Alt+F1, then uninstall Nvidia drivers from command line to at least get back into the system.

But with this one, I’m out of ideas. Where to go from here? What’s the deal with this graphics card not being recognized in the first place? The 30 series has been out for a while, so I kind of thought it wouldn’t be too much of a problem. :-/

Any help would be greatly appreciated!

you need ibt parameter if you are using newer intel+nvidia systems:

Thanks! Is there a way to do this when the system won’t boot? Pressing Ctrl+Alt+F1-F6 does nothing, neither before nor when the black screen appears.

Will I have to reinstall Manjaro and do this before installing the graphics drivers?

so manjaro is already installed?
you can add it in grub menu, press ‘E’ and ln the kernel command line add:
save it and boot…
then add the parameter as outlined above, to make it permanent

1 Like

Yeah, it’s already installed. Actually, just before you responded, I found this:

I booted with runlevel 3, was able to drop to terminal, make the changes to grub and reboot. Bingo, works!! Thanks, you made my day.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.