Rtw89 stopped working after kernel upgrade/switch to 5.15

I have a laptop LENOVO Legion 5 15ACH6H with Realtek RTL8852AE 802.11ax network controller.
Recently, I have updated my Linux kernel from 5.10 to 5.15. After that, wi-fi stopped working. (There are literally “No available connections” in the system tray).

I have installed linux515-headers and rerun pamac build rtw89-dkms-git, however I still have no available connections in the system tray.
How do I solve the problem?
Do I need to uninstall all 5.10 kernel related packages?
Could there be a conflict with some other drivers that I should blacklist? If so, how do I find conflicting drivers?

Of course, I can switch back to 5.10 kernel, where everything worked, but the system advised me to switch to 5.15.

the driver was probably dropped from the 5.15 kernel …
and what system advised you to switch?
post output from:
mhwd-kernel -li
inxi -xN

The rtw89-dkms-git package is requiring the headers - so did you remember to install the headers for the new kernel?

Even though you install a new kernel - you are required to know - the headers are not automagically included - in most cases the mhwd-kernel will pick it up.

Manjaro kernel manager said there is a newer available version and I should probably switch to it.

Output of mhwd-kernel -li:

Currently running: 5.15.60-1-MANJARO (linux515)
The following kernels are installed in your system:

  • linux510
  • linux515

Output of inxi -xN:

Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 2000 bus-ID: 03:00.0
Device-2: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
vendor: Lenovo driver: N/A port: 1000 bus-ID: 04:00.0

well if your wifi works under 5.10 you should use that kernel, thats nothing wrong with it … atleast you dont have to mess with AUR drivers and kernel headers …

As I indicate in my post, I did run pamac install linux515-headers and then pamac build rtw89-dkms-git.
I have also tried to run pacman -Syu linux515-headers and then pamac build rtw89-dkms-git, but still no luck. May be I should have used pacman in the first place, but I don’t think this is the problem.

This has nothing to do with the chosen kernel - explicitly.

It is a derived issue from using a custom package build.

A lot ot things can go awry - and it is impossible to deduct what this is in your case.

That is true. But I noticed the posts of other users who had similar complaints. So, may be an actual solution to this problem may benefit the community.
By the way, how soon will kernel 5.16 be considered stable?

The latest stable kernel is 5.19. 5.15 is LTS - you can verify on kernel.org.

Rumours are then next major kernel release will be 6.0

so if you want to run it on 5.15, did you rebooted after you installed the dkms driver?

I rebooted my system each time.

try installing the 5.18 kernel and boot with it to see if the driver is included in the newer kernel

Yes, it did help.

so the driver is included in 5.18, but there is somehting wrong with the 5.15 kernel, or the dkms driver…

Now do the same with 5.19, and if it works remove 5.18. :smiley:

Is 5.19 much better then 5.18?

It’s the bestest yet.