RTL8821CE only works without issues in kernel 5.10 or below


I’ve been using Manjaro for some time with no issues. I recently bought a new PC and found out my wireless card was not supported. I managed to install the driver in kernel 5.10 with the help of, at first, the driver provided by Tomás Pinho, and later with RTL8821CE-dkms from AUR.

When I upgraded the kernel to a version above 5.10 I noticed that there was a wireless driver that worked out of the box, but it causes my system to randomly freeze from time to time. The system freezes completely, keyboard included.

As of now, I can only use wi-fi with no issues in kernel 5.10. I tried to check the logs to see if I could find the problem or at least a hint of what makes my system freeze but I didn’t find anything (I may lack some knowledge in bug tracking).

I am not really asking for help per se, because I decided to use kernel 5.10 for now, but since it is a major issue I would ask the Devs to check this out. There may be other people with this same issue (although I searched the forums but found no issue similar to mine).

If I can be of further assistance please ask.
Thank you and keep up the good work.

HP All-in-One 22-df0xxx
Intel® Core™ i3-10100T CPU @ 3.00GHz × 8
Mesa Intel® UHD Graphics 630 (CML GT2)
Issue persists on both Manjaro XFCE and GNOME

Please read this:

Especially the Linux has multiple kernels section, then stay on 5.10 but now you know why you should. :grin:

If you insist on getting a developer to look at it, please read the section What’s this Upstream / Downstream business? in the same tutorial and then file a bug upstream

Please note that:

Closing words

Compared with other Free/Libre & Open Source Software it’s hard to report issues to the Linux kernel developers: the length and complexity of this document and the implications between the lines illustrate that. But that’s how it is for now. The main author of this text hopes documenting the state of the art will lay some groundwork to improve the situation over time.


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Seems to be a known issue if you read it on AUR:


Also, it seems that someone found a solution as well.

Then yes, you should ask the devs to check this out:

Manjaro is not the devs of this driver, nor can they do much unless they have this specific card.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.