RTL8812ua driver installed but not mapped to device

Hello all!
I bought a new network adapter (Product from amazon: B07S9W1HMM – couldn’t include links) in order to have improved speed and a more reliable connectivity.
I tried using 2 packages to make this work. The 8812ua (From GitHub: morrownr/8812au) package was installed and dkms read it properly, but it wasn’t mapped to the device for some reason.

I then tried installing rtl88xxau-aircrack-dkms-git package from the AUR, same story. I happened to follow the answer in this question (https://archived.forum.manjaro.org/t/solved-rtl8811au-how-to-install-the-wifi-driver-properly/145736).

For the current output from dkms:

rtl88xxau, r1155.c0ce817, 5.10.30-1-MANJARO, x86_64: installed

I ran sudo dmesg and when I installed the package 8812au it appeared, whereas the rtl88xxau did not. I can reinstall the other one and provide the output of that if it helps more.

Let me know how I can provide easier analysis on this topic :slight_smile:
Thanks for any support!

How do you know that the driver you want to use is actually the correct one?
checking via lspci and inxi should help to clarify

Hmm, so only inxi gave me back something useful, but I don’t believe it’s enough:

Device-3: Realtek 802.11ac NIC type: USB driver: N/A bus-ID: 3-2:7

Other than that I tried checking through lspci and lshw but nothing came back that involves the device.

Can you please provide the full output of:

inxi -Fza

There you go:

System:    Host: panzer Kernel: 5.10.30-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Console: tty pts/1 
           Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 20C600ACED v: ThinkPad Edge E540 serial: PF03WPRT 
           Mobo: LENOVO model: 20C600ACED serial: 1ZSUB4880GZ UEFI-[Legacy]: LENOVO v: J9ET88WW (2.08 ) date: 05/20/2014 
Battery:   ID-1: BAT0 charge: 27.5 Wh (82.3%) condition: 33.4/42.8 Wh (78.0%) volts: 12.1 min: 10.8 model: SMP LNV-45N1 
           status: Charging 
CPU:       Info: Quad Core model: Intel Core i7-4702MQ bits: 64 type: MT MCP arch: Haswell rev: 3 cache: L2: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 35120 
           Speed: 998 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 998 2: 998 3: 998 4: 998 5: 998 6: 998 7: 998 8: 998 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 
           Device-2: NVIDIA GK208M [GeForce GT 740M] driver: N/A bus-ID: 01:00.0 
           Device-3: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 3-12:3 
           Display: server: X.Org 1.20.11 driver: loaded: intel resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 21.0.2 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus-ID: 00:03.0 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus-ID: 00:1b.0 
           Sound Server-1: ALSA v: k5.10.30-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.25 running: no 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 4000 
           bus-ID: 04:00.0 
           IF: enp4s0 state: down mac: 28:d2:44:cd:b5:31 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lenovo driver: rtl8723be v: kernel port: 3000 
           bus-ID: 05:00.0 
           IF: wlp5s0 state: up mac: 18:cf:5e:bb:d9:95 
           Device-3: Realtek 802.11ac NIC type: USB driver: N/A bus-ID: 3-2:7 
Bluetooth: Device-1: Realtek RTL8723B Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-7:2 
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Drives:    Local Storage: total: 447.13 GiB used: 196.27 GiB (43.9%) 
           ID-1: /dev/sda vendor: Kingston model: SUV400S37480G size: 447.13 GiB 
Partition: ID-1: / size: 422.47 GiB used: 196.27 GiB (46.5%) fs: ext4 dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 16.9 GiB used: 0 KiB (0.0%) dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 230 Uptime: 58m Memory: 15.36 GiB used: 3.38 GiB (22.0%) Init: systemd Compilers: gcc: 10.2.0 
           clang: 11.1.0 Packages: 1547 Shell: Zsh v: 5.8 inxi: 3.3.04

*I might delete this once we’re done because I don’t enjoy sharing this much details about my system.

I was hoping that it would show more info of that device, but looks like it does not at all.

Checking the Amazon page comments, people say the chipset for the 600Mb/s version is:

lsusb ID: 0bda:c811 Realtek Semiconductor Corp.
chipset: Realtek rtl8821CU

It connected properly after installing the first package. I thought I was missing something on my system because I cross checked that hardware ID on another forum and it gave me the 8812ua. Thank you for putting time into this :slight_smile:
If we didn’t know from the comments that this is the driver running, do you know of any way of maybe detecting what it’s running? If not that’s okay, don’t want to waste your time.

Well… usually it’d at least tell you the chipset in inxi -Fza in the Network section. If it doesn’t show up there, and your adapter also provides bluetooth, you can check the Bluetooth section for the chipset. If it still isn’t there, maybe lspci can pull it up.

If it still isn’t there, you can check the Windows drivers and see if it says the chipset on the CD-ROM (if provided) or the manufacturer’s website. I was trying to check the manufacturer’s website for the chipset, but all of the comments say that the website is down and you can’t get the driver from their website.

You can also load into Windows, and check Device Manager for the chipset iirc.

Haha alright, fair enough hack for that. Yeah I tried to read documentation provided with the device … it actually gave 3 drivers, all 3 of them were wrong (and I was sure of that), and they didn’t even work out of the box. Wouldn’t expect the website to be working after that :stuck_out_tongue:
Notes taken on the advice. Thanks for this :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.