Rtl8812au wifi adapter repeatedly asking for network authentication


I switched to a new computer and now my WiFi adapter is not connecting to a WiFi network, but it still detects them.

I don’t have any other means of connecting to the internet on that computer except for another distro on the disk (Debian), which I assume has the correct WiFi adapter drivers.

Edit: I’d like to add that I am connecting to WiFi on a laptop as of right now, which has Arch Linux installed.

I tried to install the drivers from the AUR (whilst chrooting into the Manjaro install from Debian), but I get this error:
System has not been booted with systemd as init system (PID 1). Can't operate. Failed to connect to bus: Host is down

I’m using the 4.19.167-MANJARO kernel, and the adapter chipset is RTL8812AU. Any help would be greatly appreciated, thanks!

If you have Arch installed and a working Wifi connection through it - then it should be easy to find out which driver it uses and then use the same in Manjaro.

But I think that’s not the case - on your currently not working machine there is Debian and Manjaro, correct?
Does Debian have a working Wifi connection?

some tools to get that info on any system:
inxi (probably not installed by default in Arch or Debian)
and the system logs

Right, my new PC doesn’t have arch installed, only Debian and Manjaro. And yes, Debian does have a working WiFi connection, Manjaro doesn’t.

I’ll get around to providing command output in a bit.

… don’t just post the info.
Compare for yourself for possible different driver versions on the Debian install
(where it seems to be working?)
vs. the Manjaro install.

I executed lspci on Debian. The WiFi adapter isn’t showing up at all (It shows up on lsusb though), yet it’s managing to connect to a WiFi network.

I can’t seem to find any RTL8812AU drivers on Debian either.

On Debian, the wifi is working?
On Manjaro, which is on the same machine, it is not working?

To me that means that the RTL8812AU isn’t your problem.

It shows up on lsusb though

wifi adapters are often on the USB bus
although mine is also listed in lspci output

it shows up on Debian
but not on Manjaro?

What does it show in Debian?
What does it show in Manjaro?

The WiFi adapter is showing up on both Debian and Manjaro:
Bus 001 Device 003: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter

lsmod | grep 8812au
should show the driver loaded in both Debian and Manjaro with the same output
rfkill and cfg80211
should also be loaded

rfkill list
should show the wifi device unblocked

Executing lsmod | grep 8812au, I get the following:

8812au ​ ​ ​​ ​ ​ 1769472 0
cfg80211 ​ ​ ​ ​ 794624 1 8812au

And what do you mean by loaded, are rfkill and cfg80211 modules that I can load with modprobe?

rfkill list also gives the following output:

0: hci0: Bluetooth
​ ​ ​ ​ Soft blocked: no
​ ​ ​ ​ Hard blocked: no
1: phy0: Wireless LAN
​ ​ ​ ​ Soft blocked: yes
​ ​ ​ ​ Hard blocked: no

Additionally, I feel like I should clarify the problem in more detail; even though the WiFi networks show up, on Manjaro it keeps repeatedly asking for authentication, even when I enter the correct passphrase.

when 8812au is loaded, cfg80211 is as well
Your output shows that this is so.

I was just making sure that all the prerequisites are in order.

I’d remove the connection from NetworkManager and add it again.
Set it to “all users can use this connection” in the general tab.

I think issues similar to this have already come up here more than once.
Did your search reveal nothing helpful?

There must be some difference in configuration between Debian, where it is working
and Manjaro, where it is not.

I’d also try to boot a different kernel.

Ticking “all users can use this connection” in the General tab didn’t seem to do anything.

I actually searched all sorts of forums for a solution, but none of them seemed to have worked for me, hence why I’m making my own separate thread here.

Both Debian and Manjaro have the 4.19 kernel, but I’ll try booting into a different kernel anyway. I’ll edit this post with results.

Edit: No luck, the WiFi device doesn’t even show up on nmcli dev in a different kernel (5.10).

hmm, same kernel, same driver, same configuration - Debian works, Manjaro doesn’t
Since I don’t have that device I can just keep guessing without being able to give verified information.

Someone else probably has better advice.

Correct, but not exactly the same kernel. Although they both have the 4.19 kernel, they’re different versions; Manjaro has the 4.19.167 kernel, Debian has 4.19.0.

Thank you for trying to help regardless :slight_smile:

I figured it out!

Plugging the WiFi adapter into a different port fixed my issue; I had it plugged into a USB 2.0 port, I plugged it into a USB 3.2 port and it started working!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.