RTL88 Wifi Driver Isn't Working

I bought a new 2 in 1 Wifi + Bluetooth Dongle. And I’ve tried everything to get wifi to function but it doesn’t work, Bluetooth works flawlessly. I previously had another wifi-only dongle, which worked fine when I installed Manjaro.

This is what I have tried yet:

  • Installed Kernal 4.19, 54, 5.15.
  • Installed/Uninstalled All Drivers which I found on Github & Aur
  • Try all answers with similar questions but still it doesn’t work.

Here : mhwd-kernel -li

Currently running: 5.15.71-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux419
   * linux515
   * linux54

Here’s inxi -Nazy

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8168 v: 8.050.03-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  Device-2: Realtek 802.11n WLAN Adapter type: USB driver: btusb
    bus-ID: 3-4:6 chip-ID: 0bda:d723 class-ID: e001 serial: <filter>

And lsusb

Bus 002 Device 002: ID 8087:8000 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 006: ID 0bda:d723 Realtek Semiconductor Corp. 802.11n WLAN Adapter
Bus 003 Device 004: ID 1a81:2232 Holtek Semiconductor, Inc. Lenovo Gaming Mouse
Bus 003 Device 003: ID 04e8:6864 Samsung Electronics Co., Ltd GT-I9070 (network tethering, USB debugging enabled)
Bus 003 Device 002: ID 258a:002a SINO WEALTH Gaming KB 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Please help me to fix this.

try a newer kernel, for example the 5.19 (but not the ‘rt’ one, the normal one)

ok, let me try it.

I have tried it but it doesn’t work, it is the same.

Check this, it may help me,

pacman -Qs rtl

local/python-importlib-metadata 4.9.0-1
    Read metadata from Python packages
local/python-reportlab 3.6.11-1
    A proven industry-strength PDF generating solution
local/rtl8723de-dkms-git 7b7fc22-1
    RTL8723 wireless + bluetooth modules (DKMS)
local/serd 0.30.16-1
    Lightweight C library for RDF syntax supporting reading/ writing Turtle and NTriples


 0 bluetooth hci0   unblocked unblocked

post also output from:
pacman -Qs 'headers|dkms|git'

Hi @adarshraj32, and welcome!

According to this page, the driver is included in kernel 4.1 and newer:

The device is supported by kernel versions 4.1 and newer according to the LKDDb

And, I see there is, indeed, a driver for this device in the AUR:

$ pamac search rtl8723au
rtl8723au_bt-dkms                                                                                                                                                                                                                                0.1-1  AUR
Bluetooth driver for RTL8723AE and RTL8723AU

But for dkms packages/drivers, you need the kernel headers. So first install your kernel(s) headers:

pamac install $(pamac list --installed --quiet | grep "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

This will install the headers for all your installed kernels.

Then install the drivers:

pamac build rtl8723au_bt-dkms