RTL8723DE Wi-Fi driver for kernel 5.10


I can’t build the subj for any kernel newer than 5.8. LTS also won’t do. As the 5.8 kernel is no longer supported, the situation becomes uncomfortable.

$ yay -S rtw88-dkms-git

apparently builds drivers for both installed kernels (5.8 and 5.10), but only 5.8 works. It’s kernel panic with 5.10, which is “normal”. The trouble with RTL8723DE goes on and on indefinitely; worse still, the situation changes, and yesterday’s solutions become obsolete. There’s no corresponding entry in the Manjaro Wiki. Can anyone help me one more time? To make an entry in the Manjaro Wiki would be very kind of those who really understand the nature of the trouble.


What is the error ?
Did you install the linux520-headers ?

Is an AUR package, that can change anytime, as is outside of Manjaro packages and control.
Best to contact the packager on AUR page and point to issues.
AUR (en) - rtw88-dkms-git

Try with
pamac build rtw88-dkms-git
and report the errors you get.

$ yay -Ss linux510-headers
core/linux510-headers 5.10.2-2 (9.5 MiB 47.7 MiB) (Installed)
    Header files and scripts for building modules for Linux510 kernel

pamac build... shows the same output as yay -S.... No build errors. The final result is also the same: 5.8 works, 5.10 falls into kernel panic, just as the 5.9 earlier.

Since 5.4 kernel is LTS, i have to ask if you tried it? If works, keep it till the issues with 5.10 get fixed. That will come handy as the 5.8 is EOL and was removed upstream already. 5.9 kernel will also not be around for long.

It was my hope once, but no. I used to think that my trouble was over for the foreseeable future, but 5.4 LTS stopped working with this driver about six months ago. Right now I’m in for a real trouble.

Technically, it should be possible to have 5.4 LTS compatible version of the driver, but I have no idea how to go about it.

I used to have this wlan card in a HP laptop and got sick and tired of it being on and off.
So I ripped it out and got myself a nice intel card from China-express and all runs smooth.
No more dkms needed.

This is beyond the scope of this theme, but… How do you mean “ripped”? Is the chip plugged, not soldered, or worse?

Very easy to access.
It’s plugged in and so is the antenna cable.

No soldering needed.

Well, next update destroyed most everything, just as I feared :slight_smile: . 5.8 gone; mhwd thoughtfully installed 5.4 LTS without asking; nothing works any more. I had to remove the Wi-Fi drivers via chroot. Now dkms status shows nothing; somehow, 5.10 still won’t boot. 5.4 LTS boots, but with Ethernet down. Last time something like this happened years ago, so I’m at a loss about troubleshooting my wired connection. I’m writing this from the USB stick :slight_smile:

Did you had the linux54-headers installed ? You need the headers for each kernel you have installed, dkms and the package you need, then there should be no problem from what i gathered.

Yes, I do have everything. I can’t try and reinstall anything, because the wired connection is somehow unavailable. The hardware is OK, I’m writing this from the USB stick.

Have you tried to reboot in your system using 5.4 kernel? Do not switch to 5.10, but rather if the Lan is not working on 5.4 to reboot a few times in it. If your Lan works on USB should work on the installed system too.
Then try again with the rtw88-dkms-git

Yes, I did reboot! How many is a few ? I did it twice. Let me try it again…

Boot without the quiet option and catch any error in logs, save them so you can share them from that USB install that you mentioned has internet connection. Did you try to remove the connection ad ad it back, restart the NetworkManager.service ?

  • I can’t remove the wired connection, because there isn’t any.
  • I can’t create one; no errors, it’s just kinda unresponsive.
  • NetworkManager.service is initially running; it can be stopped and started without trouble. status doesn’t show errors.

While experimenting with the Network Manager, I don’t have any connection, I can’t google and feel generally helpless, of course :frowning:

I did a bit of research and a bit of thinking. Probably, I have to destroy NetworkManager configuration (it’s much more than the empty /etc/NetworkManager/NetworkManager.conf) and reinstall it from cache. Am I having it right (before I destroyed what I still have :slight_smile: ?


I checked the packages and corresponding files. Removed /etc/NetworkManager and reinstalled networkmanager package. Reboot; wi-fi is forgotten, as expected; still no wired network.

Do you think I have to check the remaining kernel drivers? If this is a good idea, what drivers should I check?

Will you please tell me the exact name of that intel card?

Sure, it’s an Intel 3168.
The laptop is a HP, with an i5 quad core.

Thank you very much!

You’re welcome.
It runs ootb, driver is already in the kernel.