RT Kernel 5.15 Virtualbox Host freezes on VM start

After installing kernel 5.15 and booting that kernel, Virtualbox 6.1.30 r148432 freezes. On kernel 5.10 it runs fine.
pamac search -i linux515 shows:

linux515-rt-virtualbox-host-modules                                                                                                         6.1.30-2       community 
    Host kernel modules for VirtualBox
linux515-rt-headers                                                                                                                         5.15.5_rt22-1  community 
    Header files and scripts for building modules for Linux515-rt kernel
linux515-rt                                                                                                                                 5.15.5_rt22-1  community 
    The Linux515-rt kernel and modules

The complete VBox log file shows:

00:00:00.879424 VirtualBox VM 6.1.30 r148432 linux.amd64 (Nov 22 2021 19:44:56) release log
00:00:00.879426 Log opened 2021-12-21T20:01:46.677134000Z
00:00:00.879426 Build Type: release
00:00:00.879428 OS Product: Linux
00:00:00.879429 OS Release: 5.15.5-1-rt22-MANJARO
00:00:00.879430 OS Version: #1 SMP PREEMPT_RT Wed Dec 1 16:28:32 CET 2021
00:00:00.879446 DMI Product Name: System Product Name
00:00:00.879453 DMI Product Version: System Version
00:00:00.879457 Firmware type: UEFI
00:00:00.879969 Secure Boot: Disabled
00:00:00.879996 Host RAM: 15868MB (15.4GB) total, 14927MB (14.5GB) available
00:00:00.879998 Executable: /usr/lib/virtualbox/VirtualBoxVM
00:00:00.879998 Process ID: 1825
00:00:00.879999 Package type: LINUX_64BITS_GENERIC (OSE)
00:00:00.882668 Installed Extension Packs:
00:00:00.882681   None installed!
00:00:00.883285 Console: Machine state changed to 'Starting'
00:00:00.883443 Qt version: 5.15.2
00:00:00.883449 X11 Window Manager code: 3
00:00:00.892130 SUP: seg #0: R   0x00000000 LB 0x0004d000
00:00:00.892150 SUP: seg #1: R X 0x0004d000 LB 0x0011a000
00:00:00.892155 SUP: seg #2: R   0x00167000 LB 0x00060000
00:00:00.892157 SUP: seg #3: RW  0x001c7000 LB 0x000350a0
00:00:02.902386 GUI: UIMediumEnumerator: Medium-enumeration finished!
00:00:02.902605 X Server details: vendor: The X.Org Foundation, release: 12101002, protocol version: 11.0, display string: :0
00:00:02.902616 Using XKB for keycode to scan code conversion
00:00:02.940993 GUI: UIDesktopWidgetWatchdog::sltHandleHostScreenAvailableGeometryCalculated: Screen 0 work area is actually resized to: 0x0 x 1920x1048
00:00:03.024490 GUI: Machine-window #0 activated
00:00:03.024580 GUI: Machine-view #0 focused, reason=3
00:00:03.035793 GUI: Machine-window #0 deactivated
00:00:03.035818 GUI: Releasing mouse on focus out
00:00:03.035826 GUI: Machine-view #0 unfocused, reason=3
00:03:15.040196 GUI: Machine-window #0 activated
00:03:15.040244 GUI: Machine-view #0 focused, reason=3
00:03:19.356262 GUI: Machine-window #0 deactivated
00:03:19.356296 GUI: Releasing mouse on focus out
00:03:19.356306 GUI: Machine-view #0 unfocused, reason=3

A succesful start (kernel 5.10) shows after the line SUP: Seg #3

00:00:00.857390 SUP: Loaded VMMR0.r0 (/usr/lib/virtualbox/VMMR0.r0) at 0xXXXXXXXXXXXXXXXX - ModuleInit at XXXXXXXXXXXXXXXX and ModuleTerm at XXXXXXXXXXXXXXXX
00:00:00.857406 SUP: VMMR0EntryEx located at XXXXXXXXXXXXXXXX and VMMR0EntryFast at XXXXXXXXXXXXXXXX
00:00:00.858888 Guest OS type: 'Windows7_64'

virtualbox can only be terminated via a ‘end process’. After that the system is unstable, so rebooted.

Any advice what to do?

Is there any reason your running the 5.15 RT kernel.Have you tried installing the 5.15 kernel to see if that helps. I’ve never ran an RT kernel but I have vbox installed without issues with kernel 5.15 .

2 Likes

In the past virtualbox ran fine with kernel 511 rt.
I am trying this rt kernel to reduce audio xruns (unrelated to virtualbox).
Thanks anyway.

But, I tried the 5.15 kernel without the RT, and yes, virtualbox does start normally. And 515 seems to not produce more xruns than 515 RT.

Straycat, thanks again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.