Rstudio opens but doesn't display anything but the menu header

I started a new job end of last year and so haven’t been doing any R work on my own. I wanted to start a new project today but when I went to open Rstudio but when it loads it’s just a window with a menu header and blank white everywhere else.

I tried to update R and Rstudio with sudo pacman -S r and yay -S rstudio-desktop-bin referencing the archived post by @p-value found here but that did not solve the issue.

I found this recent thread which seems similar but mine does actually open, and when I run rstudio --no-sandbox I get an error: zsh: command not found: rstudio

The rstudio command is only available if you install the rstudio-desktop package.

The rstudio-desktop-bin package provides rstudio-bin .

So you would need to use

rstudio-bin --no-sandbox
1 Like

Depending on your actual system there may be issues with qt.

rstudio needs an environment variable on which platform plugin to use - you can check

env | grep QT_

This works and gets me my RStudio session, thank you!

Normally I launch via an app launcher (I believe this is the correct term?) on my start menu/plank, so the terminal launch feels a bit like a workaround. I’m wondering if there’s something I can update so that the RStudio icon on my plank launches with that added --nosandbox argument?

Here is what I get for that:

env | grep QT_

Of course, there are different ways to do this.

For example

cp /usr/share/applications/rstudio.desktop ~/.local/share/applications

and then edit the desktop file (rstudio.desktop ) with a text editor of your liking. For exmaple

nano ~/.local/share/applications/rstudio.desktop

or any other text editor and add --nosandbox to the Exec= line

Exec=/usr/bin/rstudio-bin --nosandbox  %F

You can also edit the desktop file in /usr/share/applications/ but it gets overridden, so it is recommended to create a copy in your home, ~/.local/share/applications takes precedence. You might need to logout and in again to get it working.