RSS Feed Not Displaying Web Preview

Edit, problem is solved, typing up a tidy solution in one place now.

Hey guys, I really struggled to decide where to put this because I don’t understand the nature of the problem.

I’m using Manjaro Gnome, and while using NewsFlash OR Gnome Feeds, any time I select something on my RSS feed, in the “preview” pane to the right, I get what appears to be nothing:

However, it’s actually not nothing. When I mouse over it, I can actually see the tool tip at the bottom displaying URLs in the preview pane.

That’s the reason I’m here on the gnome one specifically for this.

I’m assuming there’s some…java something or another missing and it’s making the previews not work? I don’t think it has anything to do with the actual RSS feeds because I’ve been using NewsFlash for a long time and never had this issue previously.

I’m quite certain I added/removed something at some point that triggered this event. I don’t have the slightest idea of what. I’m not THAT tech savvy.

So, yeah. The reason I chose this specific spot to ask is because I assume there’s something system wide, probably related to gnome, that’s basically causing the same issue in multiple places.

Suggestions are appreciated. <3 Thanks in advance.

You might check that the web rendering engine is current; or, installed properly. I’m assuming it’s webkit2gtk, or similar:

sudo pacman -Syu webkit2gtk

if it isn’t.

Hey, @soundofthunder ! I appreciate the suggestion.

I checked my package manager and it does seem to be installed. For good measure, I ran the command in my terminal anyways and reinstalled it or whatever. Doesn’t appear to have made any noticeable difference. I appreciate it, though!

From the description, it could even be theme-related; another possible avenue of exploration.

Thanks for that, too. I haven’t changed it recently, but it’s not to say that it hasn’t updated or something in the process.

That said, changing my system theme doesn’t appear to have made any noticeable impact, either. It’s changing my theme in my browser and other places, but not changing my ability to see what’s inside the display pane (still just flat black/grey, even when I go light theme system wide). Nor has tinkering with the appearance settings inside the programs made any difference. (I tried that previously, too).

Is it still the same if you choose a light theme variant? (as opposed dark mode), or vice versa? Are there any custom themes under ~/.local/themes/gtk- that might affect it?

I’ve tried light and dark themes both, system wide and inside the applications. Currently, I’m still getting that same dark theme looking void of a pane over there. It’s not seemed like changing my system theme has had any impact on the RSS feed applications, though I do see it on other applications like my internet browser. And, again, for the record, there was a time in the past where these worked fine with my current dark theme. So, I’m not sure what’s going on there.

Nor am I. You could try deleting/renaming your cache directory, and rebooting, which may (or may not) be helpful.

Can text be selected in the feeds, despite it not being visible?

Weirdly enough, when I get the mouse icon to insert (the one that’s shaped like a capital “i” to insert text), when I try to highlight text, in this case, it “grabs” the whole preview pane like an image, and I can visually see the text in a transparent fashion being dragged around as long as I hold it with my mouse, then obviously disappears when I release the mouse. To be clear, I see the image following my mouse, not in the pane. The pane itself looks the same. But I can see a “ghost” of it when I drag it with the mouse.

That points to a theming issue. Gnome is working hard to make a consistent look and feel - which also applies to coloring.

It may be the app is using a layout property which no longer exist or has changed namespace.

Apply the default gnome theme and verify.

NewsFlash and Gnome Feeds appear to be Flatpak versions. Is this also true of the versions you’re using? If so, try removing those; you can install them again after a reboot to see if there’s any change; or check the Arch repo’s in case there are versions there.

You might also consider using Thunderbird’s “Blogs and Newsfeeds” feature as an alternative; if you happen to use Thunderbird.

I’ll keep the Thunderbird one in mind. Thanks for the suggestion.

I’m using the one from the official repository, though.

edit: Also deleted my cache folder. Didn’t seem to make a difference. (and restarted)

Thanks for the suggestion, @linux-aarhus .

I changed my stuff to default:

And restarted my computer. I notice my internet browser got the memo and has def shifted themes, but gnome feeds still looks exactly the same and the pane issue still persists.

According to this page about gfeeds it has it’s own light and dark modes. In its preferences there are toggle buttons of interest:

  • Dark mode
  • Use dark theme for reader mode

Play with those; disable the last of these if enabled. There is also a button [Clear Caches] that might be needed, and possiblt a reboot, to see any changes. At face value, this is likely the culprit.

I imagine the other reader may have similar preferences. I don’t use Gnome, so it’s not easy to test. However, it that toggle solves the issue for gfeeds, you can safely lose the flatpak app.


Thanks again, @soundofthunder .

  1. I cleared its cache in the settings
  2. Toggled these appearance settings
  3. Restarted my computer
  4. Reopened the app, clicked the first tab again, and you can see the settings are still supposed to have light theme, but looking in its background, you can see it doesn’t seemed to have even changed its own settings (problem still persists, also).

With those same settings, how does it appear with the default Gnome (light) theme?

I’m running out of theme-related ideas.

It’s fixed with the WebkitGTK 2.42.1-2 packages in the unstable branch. For now try:


See FS#79783 - [webkit2gtk] 2.42.x on Nvidia breaks multiple apps

1 Like

This def seems to fix it when I type this in the terminal! But, when I close the program and reopen it normally, it goes back to being broken again.

Am I going to have to keep typing this every time I want to use them for now or is there a way to make this stick?

Thanks, @Yochanan !

Add those to your profile, for example, ~/.bash_profile if you use bash:

nano ~/.bash_profile

… and then add WEBKIT_DISABLE_DMABUF_RENDERER=1 to the end of the file for gfeeds or newsflash, whichever of those you ultimately wish to keep.

At next login, magic happens; or it doesn’t.

Edit1:- Modified for clarity.

1 Like

Thanks for this!

So, I didn’t run the terminal line you said, but I did go and find the .bash_profile file and I added it at the end. I did indeed also restart the computer and it doesn’t seemed to have changed it. Did I do it wrong? Haha. Sorry. You can talk to me like I’m five if you wish.