Rpi4 B 8gb/ kde plasma/add-remove software/PGP signature

hi there.
after 1 year of trying to installing Manjaro on my rpi4 8 GB and after four or five times of losing the account , i don’t know why last week i turned on my rpi4 and it was lagging on login screen and after writing password there was nothing to show , the screen was black.whatever, i erased that sd and i started today with a new ssd and i get started , going on with basic setups, but when i went to (add- remove software) i choosed my applications to download and applying it .but there was a problem (invalid corrupted package (PGP signature)) , so i searched for that problem and i find somethings on Manjaro forum and i tried and i sloved that problem by looking at Manjaro forum.but there was another error in (add-remove software) and that was(failed to commit transaction) so i searched for that and i tried every codes about pacman and there was two errors
error1: keyring is not writable
error2:occured, no packages were upgraded
so i deleted the pacman mirrors and keyring data’s
and i have that first problem i said that in 11th line.
can someone help me?



Assuming your sd card is sdy - please adjust for your system’s sdcard reader

xzcat Manjaro-ARM-kde-plasma-rpi4-23.02.img.xz | sudo dd of=/dev/sdy bs=4M status=progress conv=fsync oflag=dsync

The above command should produce a similar result

6303178752 bytes (6,3 GB, 5,9 GiB) copied, 233 s, 27,1 MB/s6319767552 bytes (6,3 GB, 5,9 GiB) copied, 233,608 s, 27,1 MB/s

0+208859 records in
0+208859 records out
6319767552 bytes (6,3 GB, 5,9 GiB) copied, 233,933 s, 27,0 MB/s