Rpi sway & i3 broken wifi

20.10 i3 and sway images for raspberry pi have both broken wifi
Firmware Upgrade solves wifi but breaks bash

Actually to be more precise found my self I wifi usb donge and that worked
Tried to upgrade but failed

Found my self a firmware-raspberrypi-6-1.9-any.pkg.tar.zst and flashed that
That fixes the wifi issues but performing an upgrade after that throws thread ‘main’ panicked at 'unknown shell: “/bin/bash”. Errors in termite or any other terminal

20.10 is way too old for sway… please go here for a more recent base version: Releases · manjaro-arm-community/sway-images · GitHub

1 Like

Thanks for this
For whatever reason felt reasonable to trust the official manjaro download site and not look at github
flashing the newer image fixed the wifi issues

1 Like

@Strit I guess we either have to clean-up or update some of the community-supported download links here (web site and Manjaro ARM flasher)…

The website and the flasher is meant to be for official images though.

If you want to add community based images to it, you can make MR’s towards the website in gitlab.

I don’t think it’s possible to get the community editions in the Flasher, without creating more and more options for the user to choose between. But the code is on gitlab.com/Strit/manjaro-arm-flasher, so you can see if you can add it in a good way, without breaking the current setup. :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.