RPi 4b on 7" official touchscreen

I hadn’t seen many people running plasma mobile on a Raspberry Pi device with a touchscreen, so I figured I’d make a post on it incase others wanted to share their experiences and advice.

I have the RPi 4b with the official 7" touchscreen running on Manjaro Raspberry Pi, KDE edition. The setup will give you a general desktop interface upon boot, so you’ll need to install plasma-mobile and other applications.

You will also want to add the following repo to /etc/pacman.conf:


So far I use the following applications:

angelfish: A touch-based browser
qmlterminal: a terminal with extra buttons to allow touch-based programming/commands
maliit: virtual keyboard
index: file browser
foliate: an epub reader. Has an issue where the menus will not open when in plasma-mobile/wayland mode. Maybe due to being a gnome app? Some other gnome apps seem to have this issue when ran in plasma mobile (wayland)

Some pictures of the environment:

Bugs and notes:

The setup also works in portrait mode, but upon rebooting the display seems to switch back to landscape mode. Auto-rotate will not work as there is no hardware on the RPi 4 board to give the information needed.

Applications have a tendency to stall for about 5-10 seconds at times, but always seem to recover if given the time without disturbance.

You can adjust the DPI to less than 100% with plasma mobile, unlike in regular plasma. This will allow you to fully see the menus in some applications.

I don’t know where the power/logout/reboot buttons are supposed to be in plasma mobile. I just added a menu widget to the desktop to get access to them.

The virtual keyboard (maliit) will do spell checking, auto-capitalization and other functions by default. This may make you want to rip your hair out when using the terminal. You can change the settings with gsettings by first running this command to see the list of possible settings:

gsettings list-keys org.maliit.keyboard.maliit

If you wanted to know the setting value of ‘spell-checking’:

gsettings get org.maliit.keyboard.maliit spell-checking

To change the value to ‘false’:

gsettings set org.maliit.keyboard.maliit spell-checking false

The virtual keyboard can be closed by either swiping down on the keyboard or pressing the down button (which changed from an ‘X’ when the keyboard was brought up) on the right side of screen.

Feel free to share your experiences and fixes.

1 Like