Root set to wrong partition

I installed Manjaro on a disk with given paritions:

  1. /dev/sda1 : /boot/efi
  2. /dev/sda2 : something not related to linux
  3. /dev/sda3: / (root)
  4. /dev/sda4: /home

Grub does is not loading when I boot up the system. I used the live installation media to detect bootloaders and found that root is set to sda1 instead of sda3. When I change it to sda3, it works fine except that the changes are not permanent. How can I make the changes permanent ?

Did you fix it in /etc/fstab ? That’s where you fix your mounting points.

I looked at fstab, the partitions look correct. But for some reason, when I try to boot, I can’t unless I change things. Let me try to boot again and take some screenshots.

What are you changing? Grub entries?

Have a look at these images. When I change ‘hd1,gpt1’ to ‘hd1,gpt3’ and press ctrl-x, grub loads and I can boot into manjaro.

You surely do not have your fstab with /dev/sdXX identification for your partitions, do you?

Please show us what your /etc/fstab looks like.

This is my fstab file:

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=CD23-C58F                            /boot/efi      vfat    umask=0077 0 2
UUID=2ddc7949-38b7-4590-8277-d7cbe9ef6b0d /              ext4    defaults,noatime 0 1
UUID=08c599ca-c8b0-4bea-86db-c886cb29657c /home          ext4    defaults,noatime 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Can you also show the output of blkid? So that we can see if those UUID’s match.

OK good you’re using UUIDs

/dev/sda1: UUID="CD23-C58F" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="9bcb17cf-bffb-3c48-90ce-11634006b047"
/dev/sda2: LABEL="Local Disk E" BLOCK_SIZE="512" UUID="744955AB080DE16E" TYPE="ntfs" PARTUUID="444b898c-8b47-4f61-a8c6-4d613a7eea74"
/dev/sda3: UUID="2ddc7949-38b7-4590-8277-d7cbe9ef6b0d" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="dad1369b-1f1c-224c-81a0-9b547beb2afb"
/dev/sda4: UUID="08c599ca-c8b0-4bea-86db-c886cb29657c" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="b72e8ada-c993-f547-9ffa-e9fc84dffab2"

I found someone with exactly the same problem as mine. For some reason, the EFI partition is given a legacy_boot flag instead of boot, even though I explicitly set the flag to boot during the installation.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.