Root partition not found

Having installed manjaro cinnamon 21.0.7 , When booting into the system I get straight into the emergency root shell. Problem is the root partition UUID cannot be found. After booting from the live USB and mounting the the NVME root partition on /mnt and inspecting the fstab file the UUID is the one not found when booting the system. I have also tried installing the mate version with which gives same problem.

@motut is fstab file inact?

Hi hisham_6c5
Thanks for responding. Do you mean is it executable?

No, that file is never executable.
Is the syntax of that file correct and does the UUID to be mounted as the root fs match the UUID of your error message?

$ cat /etc/fstab

Does the kernel get a UUID to use in its cmdline?

$ cat /proc/cmdline


have a look at this post, it looks like you’ve come across the same problem:

Hi freggel.doe
The UUID to be mounted matches the error message one.
there is no cmdline in dir proc

  • UEFI or BIOS mode?
  • encrypted or non-encrypted?
  • dual boot or single Linux system?

Please share /etc/fstab file and UUID’s by posting here

cat /etc/fstab
sudo BLKID
sudo fdisk -l

Sorry, the leading slash was missing. I’ve updated the post.
But since the system doesn’t boot, this would not be present :thinking:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.

Thank you for responding, however it does not work for me. :sleepy:

Hi Wollie
Thank you for responding
UEFI mode I think
dual boot with Ubuntu 20.04 LTS

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=945B-61FA                            /boot/efi      vfat    umask=0077 0 2
UUID=e3284cc7-0fe1-4453-8072-5dbbc40bdc36 /              ext4    defaults,noatime 0 1
UUID=53bf4c40-ab4e-42f7-96b9-14e9db25101a /home          ext4    defaults,noatime 0 2
[manjaro-cinnamon /]# blkid
/dev/sda1: BLOCK_SIZE="2048" UUID="2021-04-21-08-48-25-00" LABEL="MANJARO_CINNAMON_2102" TYPE="iso9660"
/dev/sda2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="176E-4A11" BLOCK_SIZE="512" TYPE="vfat"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/nvme0n1p1: UUID="945B-61FA" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="6bd6968b-6959-4b49-a5f3-c0719d8df4fd"
/dev/nvme0n1p2: UUID="31d9b530-fce2-4888-86bd-3597998b0ea3" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="ubuntu-root" PARTUUID="54096a78-b795-4175-a6c9-469fa3f7bcdf"
/dev/nvme0n1p3: UUID="ebb0eb7b-6b67-4489-be67-f919311e56b9" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="ubuntu-home" PARTUUID="a0d6ceec-3c7a-4cbe-bd32-b7bb760a67cd"
/dev/nvme0n1p4: UUID="d1b3f081-60f5-45d6-82cb-a832bdd6ac93" TYPE="swap" PARTUUID="fcfe3be4-ce5b-476b-8ba5-d2e2410e8515"
/dev/nvme0n1p5: UUID="e3284cc7-0fe1-4453-8072-5dbbc40bdc36" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="manjaro-root" PARTUUID="aa957202-fbb9-4d29-96aa-91d744c80a3a"
/dev/nvme0n1p6: UUID="53bf4c40-ab4e-42f7-96b9-14e9db25101a" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="manjaro-home" PARTUUID="61f5776e-b651-4a0b-b305-9382f25c7393"
/dev/nvme0n1p7: PARTLABEL="veracrypt" PARTUUID="67e1b476-068e-45db-949d-bda56f21e4e6"
/dev/nvme0n1p8: UUID="0589c83c-1f9a-470b-b172-cdd8decb91b5" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="timeshift" PARTUUID="6490fb95-ee67-4f2d-be7d-5ded1c50236f"
[manjaro-cinnamon /]# 


I would try to boot a live ISO in UEFI mode and restore the boot loader as described here:

Make sure to follow the EFI System description and not the BIOS description.

Hi Wollie
THanks for trying, I think I will give it up. I have installed this system on an older hp laptop with no problems. I guess this version does not like nvme partitions. I will use my older system with manjaro and the newer system with ubuntu.
It is a pity that the installation media cannot detect problems after it has "successfully@ installed the system
Best wishes

Hi again Wollie

I have connected an SSD to a USB slot and installed manjaro on it with no problem it seems to like the /dev/sda partitions.