Root Partition Filling Up

This partition used to be ~3.7G used and recently spiked up to 11G out of no where:

/dev/mmcblk2p2 15G 11G 3.3G 77%

ncdu -x / output:

. 2.3 GiB [##########] /usr
. 1.3 GiB [##### ] /var
21.4 MiB [ ] /home
. 8.1 MiB [ ] /etc
! 16.0 KiB [ ] /lost+found
12.0 KiB [ ] /srv
. 8.0 KiB [ ] /opt
! 4.0 KiB [ ] /root
4.0 KiB [ ] /mnt
4.0 KiB [ ] overlay.txt

Above output gives me the ~3.7G that I was expecting
but I can’t find ~7.6G anywhere in the system using these tools, what else can I use?

Have you tried cleaning out the package cache? :arrow_down:

sudo paccache -rvk0

Result: (disk space saved: 389.5 MiB)

The strange thing is I can’t find any directories that are more than the original 3.4G.
Is it possible that these are hidden files?

Not normally, no. Hidden files are user-specific configuration data ─ usually in plain text format ─ and cache files. :man_shrugging:

I strongly recommend , ncdu
It is a little slow when it has to read lots of files
q to quit, d to delete, start as root/sudo to delete anything

I used ncdu as well but still not finding anything close to the amount I’m looking for

I’m not really shure about your system configurations.

3 points I think are worth investigating:

  • in your list there is no /usr directory which is likely filled
  • /opt usually contains more than 8KiB
    leading to the last
  • overlay.txt indicates that there is an overlay filesystem involved. Could it be that you are looking at the changes only?

Does df -h reveal any more? Re. @a-sassermann’s comment:

As that isn’t shown in your output maybe it will with the above command.

Hope this helps.

first line in OP shows the df -h output for that partition

missed it on copy/paste, updated above

And what’s the output of sudo ncdu / ?

714.4 GiB [##########] /mnt
2.3 GiB [          ] /usr
1.3 GiB [          ] /var
52.7 MiB [          ] /boot
21.4 MiB [          ] /home
16.3 MiB [          ] /root
8.2 MiB [          ] /etc
1.4 MiB [          ] /run
16.0 KiB [          ] /opt
e  16.0 KiB [          ] /lost+found
12.0 KiB [          ] /srv
 4.0 KiB [          ]  overlay.txt
.   0.0   B [          ] /proc
0.0   B [          ] /sys
0.0   B [          ] /dev
0.0   B [          ] /tmp
@   0.0   B [          ]  sbin
@   0.0   B [          ]  lib
@   0.0   B [          ]  bin

/mnt is external SSD so irrelevant

Have you looked in the /mnt directory, without the external drive mounted?

theres nothing extra there when mounted, why unmount?

Maybe they are marked deleted but kept open, like this? :

If you have files in /mnt and you mount over it, you will not see the files under the mount. They continue to take up space on /. Basically, just as you are describing. Lost disk space and no files to account for that lost space.

1 Like

I had deleted files from /mnt that were sent there on accident so its possible, but why is it showing up as used in /dev/mmcblk2p2 and not /dev/sda1 (SSD)?

ok that makes sense ill check

closer! mount --bind / /mnt & du -shx /mnt output shows me:

3.7G /

“You save me a lot of time, I have a backup script which performs its operations by anacron from ssd to hdd, and when I temporary removed hdd it had pushed a backup to hdd mount point. And of course I didn’t catch this.”

this is basically what happened - how can I delete the files under the mount?

When you unmount from that mountpoint, those files will be accessible. :wink: