Root is RW, but all other drives are RO

I’m new to the forums, and I normally don’t consider posting until I’ve exhausted what my peanut-brain can find on the internet that already exists. I very recently decided to dive into XFCE and I switched from windows 10 to XFCE on my daily driver. I’ve read a bunch of related posts across the net, more than I can list, and I haven’t found the right fix. I’m sure I’m just overlooking something simple. The first recommendations that I tried were found elsewhere and might have complicated the issue, we’ll see. What I’ve tried:

1: nfts-3g

2: Gparted: I reformated and remounted all the drives that were affected. They are all single partition ext4 drives. Still read only

3: For one of the drives (500gb ssd) I created mount /mnt/500SSD and added the drive to fstab via this code:
#UUID=9f6e5cce-b6a0-4e4a-8a68-736d7d301abd /mnt/500SSD ext4 auto,user,rw 0 0#
after that didn’t work I replaced it:
#UUID=9f6e5cce-b6a0-4e4a-8a68-736d7d301abd /mnt/500SSD ext4 defaults 0 1#

As it currently stands, the 500ssd is mounted in /mnt/500SSD and shows as ext4 with file permissions as follows:
Owner: root
Access: Read and write
Group: root
Access: Read only
Others: Read only

The only thing I could guess is that I need to change the group or something. I’m more of a GUI using pleb so you’ll have to forgive me. I have most of my experience in ubuntu. Another thing I read was related to a windows 10 setting, and since I replaced windows 10 on install. If it helps give any more context, I’ve also had windows attempt to repair my computer after restarting, and I have to boot into Manjaro in the boot menu, even though the other drives are empty.

If you want to be able to access it as a regular user then you should change the ownership of the drive.
Then if you want it automatically mounted you can set it in fstab.

See for example this:

(note that in that case it was creating a usable directory … you can apply the same thing to the whole partition as well)

1 Like

Ah, I see. I think I can figure out the specifics from that:
#sudo chmod o+w /mnt/500SSD#
…and that worked. I am now free to fill my drives with trash.
Thanks for pointing me towards chmod, and as I guessed, I was just missing an obvious solution.

The permissions thing comes up a lot with folks new to that kind of permissions structure - write a new USB as ext4 and then “why cant I use it”. It makes sense once you get used to it.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.