Rockstar Launcher Crash with GTA IV Complete Edition

inxi output

  Kernel: 6.6.16-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=40809886-d17c-433b-876f-89a03d053b64 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 45.4 tk: GTK v: 3.24.41 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: GDM v: 45.0.1 Distro: Manjaro
    base: Arch Linux
  Type: Desktop System: Gigabyte product: AB350-Gaming v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AB350-Gaming-CF v: x.x serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends v: F21 date: 02/08/2018
  Message: No system battery data found. Is one present?
  System RAM: total: 16 GiB available: 15.57 GiB used: 5.27 GiB (33.8%)
  Message: For most reliable report, use superuser + dmidecode.
  Array-1: capacity: 64 GiB slots: 4 modules: 2 EC: None
    max-module-size: 16 GiB note: est.
  Device-1: Channel-A DIMM 0 type: no module installed
  Device-2: Channel-A DIMM 1 type: DDR4 detail: synchronous unbuffered
    (unregistered) size: 8 GiB speed: 2133 MT/s volts: note: check curr: 1
    min: 1 max: 1 width (bits): data: 64 total: 64 manufacturer: TeamGroup
    part-no: UD4-3000 serial: <filter>
  Device-3: Channel-B DIMM 0 type: no module installed
  Device-4: Channel-B DIMM 1 type: DDR4 detail: synchronous unbuffered
    (unregistered) size: 8 GiB speed: 2133 MT/s volts: note: check curr: 1
    min: 1 max: 1 width (bits): data: 64 total: 64 manufacturer: TeamGroup
    part-no: UD4-3000 serial: <filter>
  Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen level: v3
    note: check built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1
    stepping: 1 microcode: 0x8001129
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB
    desc: 2x8 MiB
  Speed (MHz): avg: 1946 high: 3072 min/max: 1550/3200 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1474 2: 1550
    3: 1550 4: 1392 5: 2844 6: 3072 7: 1357 8: 1550 9: 2737 10: 2872 11: 1412
    12: 1550 bogomips: 76670
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb
    cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c
    flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate irperf lahf_lm
    lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx
    nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter
    pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni
    popcnt pse pse36 rapl rdrand rdseed rdtscp rep_good sep sev sha_ni skinit
    smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock
    syscall tce topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme
    vmmcall wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Micro-Star MSI
    driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 08:00.0 chip-ID: 10de:1c02
    class-ID: 0300
  Device-2: Logitech CrystalCam driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-2:3 chip-ID: 046d:0894
    class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
    compositor: gnome-shell driver: X: loaded: nvidia gpu: nvidia display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 3840x1215 s-dpi: 96 s-size: 1016x321mm (40.00x12.64")
    s-diag: 1066mm (41.95")
  Monitor-1: DVI-D-0 pos: primary,top-left res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: HDMI-0 pos: bottom-r res: 1920x1080 hz: 75 dpi: 93
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2
    memory: 2.93 GiB
  API: Vulkan v: 1.3.276 layers: 6 device: 0 type: discrete-gpu name: NVIDIA
    GeForce GTX 1060 3GB driver: nvidia v: 545.29.06 device-ID: 10de:1c02
    surfaces: xcb,xlib
  Device-1: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 08:00.1 chip-ID: 10de:10f1 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: Logitech CrystalCam driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-2:3 chip-ID: 046d:0894
    class-ID: 0102 serial: <filter>
  API: ALSA v: k6.6.16-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off with: 1: a2jmidid status: off 2: nsmd
    status: off tools: cadence,jack_control,jack_mixer,qjackctl
  Server-3: PipeWire v: 1.0.3 status: active with: 1: pipewire-media-session
    status: active 2: pipewire-alsa type: plugin tools: pw-cat,pw-cli
  Server-4: PulseAudio v: 17.0 status: active with: pulseaudio-jack
    type: module tools: pacat,pactl,pavucontrol
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Broadcom BCM4360 802.11ac Dual Band Wireless Network Adapter
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 07:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  IF: wlp7s0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  WAN IP: <filter>
  Device-1: ASUSTek ASUS USB-BT500 driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1:2 chip-ID: 0b05:190e
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10
    status: discoverable: no pairing: no
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 3.41 TiB used: 1.18 TiB (34.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EZAZ-00L9GB0
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 0A80
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 3B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST3500312CS
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: HDD rpm: 5900 serial: <filter> fw-rev: CA12 scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Samsung model: SSD 870 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 3B6Q
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: BD-RE BH30N rev: A201
    dev-links: cdrom
  Features: speed: 40 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 177.73 GiB (78.0%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: 40809886-d17c-433b-876f-89a03d053b64
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 80.3 MiB (26.8%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: NO_LABEL
    uuid: E832-7B45
  ID-3: /run/media/nicholas/fourth-disk raw-size: 931.51 GiB
    size: 915.82 GiB (98.31%) used: 830.8 GiB (90.7%) fs: ext4 dev: /dev/sdd
    maj-min: 8:48 label: fourth-disk uuid: 1be4d25b-4ff6-40b0-a5c7-dfe6cc409b83
  ID-4: /run/media/nicholas/second disk raw-size: 434.51 GiB
    size: 426.62 GiB (98.18%) used: 180.31 GiB (42.3%) fs: ext4 dev: /dev/sdc2
    maj-min: 8:34 label: second disk uuid: 1ec047b4-ec64-4d28-8893-f16ad7899256
  ID-5: /run/media/nicholas/third-disk raw-size: 1.82 TiB
    size: 1.79 TiB (98.37%) used: 17.7 GiB (1.0%) fs: ext4 dev: /dev/sda
    maj-min: 8:0 label: third-disk uuid: 31f2d06a-293c-46c3-9216-27dc993cfb4e
  Alert: No swap data was found.
  ID-1: /dev/sdc1 maj-min: 8:33 size: 31.25 GiB fs: swap label: N/A
    uuid: 14863704-322a-453c-b7a5-87bba34bb094
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-1:2 info: ASUSTek ASUS USB-BT500 type: bluetooth driver: btusb
    interfaces: 2 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 500mA chip-ID: 0b05:190e class-ID: e001 serial: <filter>
  Device-2: 1-2:3 info: Logitech CrystalCam type: video,audio
    driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 500mA
    chip-ID: 046d:0894 class-ID: 0102 serial: <filter>
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 3-3:2 info: Ducky One 3̠ type: HID,keyboard,mouse
    driver: hid-generic,usbhid interfaces: 5 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 100mA chip-ID: 3233:1011 class-ID: 0300
    serial: <filter>
  Device-2: 3-4:3 info: Logitech G502 Proteus Spectrum Optical Mouse
    type: mouse,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 300mA
    chip-ID: 046d:c332 class-ID: 0300 serial: <filter>
  Hub-4: 4-0:1 info: super-speed hub ports: 4 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 37.6 C mobo: 29.0 C
  Fan Speeds (rpm): cpu: 0 fan-1: 0 fan-3: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.36 vbat: 3.21
  Processes: 363 Power: uptime: 5h 43m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.22 GiB services: gsd-power,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 2474 pm: pacman pkgs: 2460 libs: 608 tools: gnome-software,pamac
    pm: flatpak pkgs: 5 pm: snap pkgs: 9 Compilers: clang: 16.0.6 gcc: 13.2.1
    Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.33

At first Rockstar Launcher would throw an error related to not being usable with Windows 7 or 8 so I changed the version to Windows 10 in the prefix. Now the Rockstar Launcher will run, ask to check for saves on Windows Live, find none, then close itself and stop the GTA IV process.

I have a Proton Log but it is too massive to post but I can share it in another way if someone has a recommendation.

Edit: Uninstalled and reinstalled the game a bunch of times. It works now! No idea why, I think the Rockstar launcher updated. Hopefully it stays working!

Many reports at protondb are suggesting

WINEDLLOVERRIDES="dinput8=n,b" %command%

Thanks for the response. I tried that before but think it’s unrelated, the people using that are using it alongside a mod to get it to work properly.

I found the problem after i looked for “GTA4 play under Linux” Its a dll, what you need to replace, because Windows live is broken.

I’m pretty sure those instructions are for the original GTA IV and not GTA IV: The Complete Edition (which replaced it on Steam 4 years ago and doesn’t include Games for Windows Live).

i’m not familiar with all of this,but can’t you just skip the launcher,or is mandatory?

That is weird the launcher is asking for GFWL saves then.

I think it’s mandatory but I don’t know!

This looks like it’s on the right path but still can’t get this game working. Tried the xlive.dll and the launcher is still not working right.

Did you try to intall the launcher with Lutris? They got a version of 2019 there, plus, they set up already a windows like user for each installation.
I am not sure, if it looks for a place to store on this Windows live cloud or just somewhere at the hdd.

How would I go about installing the launcher through Lutris then using it in Steam?

The launcher is asking to check for cloud save data with Windows Live, and then checking for local save data. What is weird is that I chose not to use cloud saves when it prompted.

Edit: Figured out the Lutris install.

I installed the launcher but how do I use it with GTA IV in Steam?

Install Steam, then add and update the game?
Some answers can also be found on the web, when you do a search with the keywords.

Thanks, I haven’t been able to find any answers which is why I posted here.

Search like “GTA4 Linux Steam”? Lesser terms are sometimes more.
I got a manual here ie.
Does that not work for you?

Even i would, before i past something into the Proton-folder, i would try first at lutris different versions of proton, or any other versions what it provides there at configuration. Second, always document it ie. in a file, when i past something into a folder. And second, never overwrite, better rename, then past files.

At the comments sections is also another hint.
“Essentially you would have to locate your rockstar games directory and then locate GTA IV. Then put said save game files in the GTA IV rock star games directory. Something like this
./Rockstar Games/GTA IV/savegames/”

Its just not clear for me, if you try to run a regular version with steam or whatelse.
I am also not very familiar with steam, so the best thing i can do is to show you some hints, what you can find already actually.

You probably didn’t see my edit but the game works now. I think Rockstar updated the launcher?

I did try different Proton versions and things beforehand, though. It wasn’t clear to me either what was happening, I had a log file from Proton and there wasn’t any specific error that I could trace. As for Lutris, I am not sure how to use the Rockstar Launcher in Lutris through Steam or if it is even possible.

Thank you for the help. That guide for the xlive.dll was helpful but outdated I think. Always fun to learn things.

Nice. Well, i saw the edit, but was not sure, if you mean, the game now runs, or the game runs now with steam.
Anyway, i think you can use your first post then and mark it as solution, then the topic will be marked as solved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.