RockPro 64 with Pine Wifi Module

Has anyone tried the Pine wifi module on the RockPro 64 with the Manjaro KDE release?

The pine wifi module doesn’t appear to detected. Just wondering if it’s something I did wrong or it’s just not supported in Manjaro KDE version yet.


Sounds like you are missing the firmware for it.

Install ap6256-firmware and reboot.

thanks for the suggestion. unfortunately it didnt enable the wifi interface.

sudo pacman -S ap6256-firmware

Strange because that’s the chipset ap6256 from the pinestore webpage.

I just noticed my version is stamped ap6359sa. Is there a package for this firmware?

Not in our repo no.

You sure the module you have is for the RockPro64?

Yes. I bought it from pine store all at the same time as the rockpro64. It works with other distros on rockpro64.

Please share the link of this module.

If it have this stamp then it must be an updated chip.

Currently we don’t package for this chip but you can just copy paste the firmware from other distro for testing and if it works then we can make a pkg of it.

I think the image I used from Mr Fixit worked a few months ago

Something from on the chipset

Hi normanT,
I have an Ugoos Am6 plus that I can run the Manjaro ARM for VIM(3) release on (xfce version, but I don’t think that matters). The Ugoos has the brcm4359 WiFi/BT chip packed in the AM6398S module, and both Bluetooth and WiFi 2.4/5GHz works just fine.
You need to locate the Manjaro package in which (most of) these files can be found (in the folder /usr/lib/firmware/brcm/):



(I don’t have the box running now.) Alternatively, you can go fishing on the interwebz for these files. After they have been put in place, a little renaming and fixing needs to be done, guided by what error messages you can (i.e. will) find in your dmesg.

Edit: The brcfmac kernel module is the one that has support for these chips, but I don’t know if that module is available in the kernel package for your board (it was for the VIM image).
Edit2: Damn, these numbers and names; I mixed up AP6359SA with AP6398S, but it is still the same procedure, and some other person (JFL) in the TV box thread has gone through the very same procedure (supposedly) for the AP6356S(A) package.

Should be provided in linux-firmware Package. Can you install it and see if it saw conflict with those manually copied files?